cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-12422) Media does not play when the App is in the background on iOS
Date Wed, 15 Feb 2017 08:07:42 GMT

    [ https://issues.apache.org/jira/browse/CB-12422?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15867429#comment-15867429
] 

ASF GitHub Bot commented on CB-12422:
-------------------------------------

Github user cordova-qa commented on the issue:

    https://github.com/apache/cordova-plugin-media/pull/128
  
    Cordova CI Build has one or more failures. 
    
    **Commit**     - [Link](https://github.com/apache/cordova-plugin-media/pull/128/commits/0969777bb9b2de7601d7bec28fac21b68a24ca9d)
    **Dashboard** - [Link](http://cordova-ci.cloudapp.net:8080/job/cordova-plugin-media-pr/97/)
    
    | Builder Name  | Console Output | Test Report | Device Logs  |
    |     :---:     |     :---:      |   :---:     |     :---:    |
    | [Windows 10  Store]( http://cordova-ci.cloudapp.net:8080/job/cordova-plugin-media-pr/97//PLATFORM=windows-10-store/)
| [Link]( http://cordova-ci.cloudapp.net:8080/job/cordova-plugin-media-pr/97//PLATFORM=windows-10-store/console)
| [Link]( http://cordova-ci.cloudapp.net:8080/job/cordova-plugin-media-pr/97//PLATFORM=windows-10-store/testReport/)
| [Link]( http://cordova-ci.cloudapp.net:8080/job/cordova-plugin-media-pr/97//PLATFORM=windows-10-store/artifact/)
|
    | [iOS 9.3]( http://cordova-ci.cloudapp.net:8080/job/cordova-plugin-media-pr/97//PLATFORM=ios-9.3/)
| [Link]( http://cordova-ci.cloudapp.net:8080/job/cordova-plugin-media-pr/97//PLATFORM=ios-9.3/console)
| [Link]( http://cordova-ci.cloudapp.net:8080/job/cordova-plugin-media-pr/97//PLATFORM=ios-9.3/testReport/)
| [Link]( http://cordova-ci.cloudapp.net:8080/job/cordova-plugin-media-pr/97//PLATFORM=ios-9.3/artifact/)
|
    | [iOS 10.0]( http://cordova-ci.cloudapp.net:8080/job/cordova-plugin-media-pr/97//PLATFORM=ios-10.0/)
| [Link]( http://cordova-ci.cloudapp.net:8080/job/cordova-plugin-media-pr/97//PLATFORM=ios-10.0/console)
| [Link]( http://cordova-ci.cloudapp.net:8080/job/cordova-plugin-media-pr/97//PLATFORM=ios-10.0/testReport/)
| [Link]( http://cordova-ci.cloudapp.net:8080/job/cordova-plugin-media-pr/97//PLATFORM=ios-10.0/artifact/)
|
    | [Android 4.4]( http://cordova-ci.cloudapp.net:8080/job/cordova-plugin-media-pr/97//PLATFORM=android-4.4/)
| [Link]( http://cordova-ci.cloudapp.net:8080/job/cordova-plugin-media-pr/97//PLATFORM=android-4.4/console)
| [Link]( http://cordova-ci.cloudapp.net:8080/job/cordova-plugin-media-pr/97//PLATFORM=android-4.4/testReport/)
| [Link]( http://cordova-ci.cloudapp.net:8080/job/cordova-plugin-media-pr/97//PLATFORM=android-4.4/artifact/)
|
    | [Android 5.1]( http://cordova-ci.cloudapp.net:8080/job/cordova-plugin-media-pr/97//PLATFORM=android-5.1/)
| [Link]( http://cordova-ci.cloudapp.net:8080/job/cordova-plugin-media-pr/97//PLATFORM=android-5.1/console)
| [Link]( http://cordova-ci.cloudapp.net:8080/job/cordova-plugin-media-pr/97//PLATFORM=android-5.1/testReport/)
| [Link]( http://cordova-ci.cloudapp.net:8080/job/cordova-plugin-media-pr/97//PLATFORM=android-5.1/artifact/)
|
     



> Media does not play when the App is in the background on iOS
> ------------------------------------------------------------
>
>                 Key: CB-12422
>                 URL: https://issues.apache.org/jira/browse/CB-12422
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Plugin Media
>    Affects Versions: 3.5.0
>         Environment: iOS 8+
>            Reporter: Remi Boardman
>            Assignee: jcesarmobile
>            Priority: Minor
>              Labels: background, background-audio, easyfix, ios, media
>
> While trying to trigger a sound to play in the App (running in the background or screen
locked) via a button press on an external bluetooth device, I receive the error:
> _"message":"","code":4_
> I've also tried creating a new blank app and wrapping the play method in a timeout so
that it triggers a short while after I lock the screen or minimise the App. I do not hear
a sound until I reopen the App and I don't get any errors in console this way.
> I have set the _playAudioWhenScreenIsLocked_ option to true, despite this being true
by default.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message