cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Maik Tizziani (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CB-12280) Problems with Phonegap Build and Camera Plugin
Date Tue, 20 Dec 2016 11:09:58 GMT

     [ https://issues.apache.org/jira/browse/CB-12280?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Maik Tizziani updated CB-12280:
-------------------------------
    Environment: cordova-plugin-camera and Phonegap-Build  (was: Since Friday the 17th Dec
2016 IOS needs additional Information on the Camera Plugin for Camera-Usage and Library-Usage.
Version 2.1.0 doesn't support this option but worked fine before for Android and Apple. Version
2.3.x works fine with the additional Info on Apple, Android builds are crashing now. First
error was that i have to use grandle. Thas was easy to fix by use "preference android-buil-option
grandle" but after that phone gives me the next error that i can't fix:

Some official plugins have to be updated if using PhoneGap >= 4.0.0. Please upgrade the
version of any plugins that may include the following file: CordovaUri.java


my workaround this time is to load version 2.1.0 only with android and 2.3.x with options
only for ios.

is there a workaround to get 2.3.x to get run on android too?
)

> Problems with Phonegap Build and Camera Plugin
> ----------------------------------------------
>
>                 Key: CB-12280
>                 URL: https://issues.apache.org/jira/browse/CB-12280
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: AllPlatforms
>         Environment: cordova-plugin-camera and Phonegap-Build
>            Reporter: Maik Tizziani
>
> Since Friday the 17th Dec 2016 IOS needs additional Information on the Camera Plugin
for Camera-Usage and Library-Usage. Version 2.1.0 doesn't support this option but worked fine
before for Android and Apple. Version 2.3.x works fine with the additional Info on Apple,
Android builds are crashing now. First error was that i have to use grandle. Thas was easy
to fix by use "preference android-buil-option grandle" but after that phone gives me the next
error that i can't fix:
> Some official plugins have to be updated if using PhoneGap >= 4.0.0. Please upgrade
the version of any plugins that may include the following file: CordovaUri.java
> my workaround this time is to load version 2.1.0 only with android and 2.3.x with options
only for ios.
> is there a workaround to get 2.3.x to get run on android too?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message