cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matt Thompson (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CB-12099) [SplashScreen] AutoHideSplashScreen not respected, Screen Flicker
Date Tue, 01 Nov 2016 15:14:58 GMT

     [ https://issues.apache.org/jira/browse/CB-12099?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Matt Thompson updated CB-12099:
-------------------------------
    Description: 
I'm using Cordova (v6.4.0) and the Splashscreen plugin (v4.0.0) (https://github.com/apache/cordova-plugin-splashscreen).


The various splash screen images I set are displaying on both Android and iOS devices. However,
on Android devices there is a white flash between the splash screen images and my app loading.

In my Cordova config.xml file, I have the following lines for the splash screen:

{code:xml}
<preference name="SplashScreenDelay" value="2000" />
<preference name="ShowSplashScreenSpinner" value="false" />
{code}

I tried disabling the splash screen image from automatically hiding and increasing the delay
before the splash screen hides by adding the additional following lines to config.xml:

{code:xml}
<preference name="AutoHideSplashScreen" value="false" />
<preference name="SplashScreenDelay" value="10000" />
{code}

Because auto hide is false and the delay is 10 seconds, I should see the static loading image
for a full 10 seconds, but on both iOS and Android it only displays for a second or two. I'm
guessing that is the root of the problem.

Once auto hide can be disabled, I hoped to manually trigger hiding the splash screen within
my app's main init function using:

{code:javascript}
navigator.splashscreen.hide(); 
{code}

  was:
I'm using Cordova (v6.4.0) and the Splashscreen plugin (v4.0.0) (https://github.com/apache/cordova-plugin-splashscreen).


The various splash screen images I set are displaying on both Android and iOS devices. However,
on Android devices there is a white flash between the splash screen images and my app loading.

In my Cordova config.xml file, I have the following lines for the splash screen:

<preference name="SplashScreenDelay" value="2000" />
<preference name="ShowSplashScreenSpinner" value="false" />

I tried disabling the splash screen image from automatically hiding and increasing the delay
before the splash screen hides by adding the additional following lines to config.xml:

<preference name="AutoHideSplashScreen" value="false" />
<preference name="SplashScreenDelay" value="10000" />

Because auto hide is false and the delay is 10 seconds, I should see the static loading image
for a full 10 seconds, but on both iOS and Android it only displays for a second or two. I'm
guessing that is the root of the problem.

Once auto hide can be disabled, I hoped to manually trigger hiding the splash screen within
my app's main init function using:

navigator.splashscreen.hide(); 


> [SplashScreen] AutoHideSplashScreen not respected, Screen Flicker
> -----------------------------------------------------------------
>
>                 Key: CB-12099
>                 URL: https://issues.apache.org/jira/browse/CB-12099
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Plugin SplashScreen
>    Affects Versions: 4.0.0
>            Reporter: Matt Thompson
>            Priority: Minor
>
> I'm using Cordova (v6.4.0) and the Splashscreen plugin (v4.0.0) (https://github.com/apache/cordova-plugin-splashscreen).

> The various splash screen images I set are displaying on both Android and iOS devices.
However, on Android devices there is a white flash between the splash screen images and my
app loading.
> In my Cordova config.xml file, I have the following lines for the splash screen:
> {code:xml}
> <preference name="SplashScreenDelay" value="2000" />
> <preference name="ShowSplashScreenSpinner" value="false" />
> {code}
> I tried disabling the splash screen image from automatically hiding and increasing the
delay before the splash screen hides by adding the additional following lines to config.xml:
> {code:xml}
> <preference name="AutoHideSplashScreen" value="false" />
> <preference name="SplashScreenDelay" value="10000" />
> {code}
> Because auto hide is false and the delay is 10 seconds, I should see the static loading
image for a full 10 seconds, but on both iOS and Android it only displays for a second or
two. I'm guessing that is the root of the problem.
> Once auto hide can be disabled, I hoped to manually trigger hiding the splash screen
within my app's main init function using:
> {code:javascript}
> navigator.splashscreen.hide(); 
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message