cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Doug Estey (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (CB-11906) Ajax call fails on iOS 10 but works fine on previous versions for Cordova application
Date Wed, 02 Nov 2016 12:41:58 GMT

    [ https://issues.apache.org/jira/browse/CB-11906?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15591840#comment-15591840
] 

Doug Estey edited comment on CB-11906 at 11/2/16 12:41 PM:
-----------------------------------------------------------

Can also confirm this bug. Timeout values past 60 seconds (jQuery/Angular/vanilla XHRs, makes
no difference) are being completely overridden by this behaviour (lower timeouts still work.)

Especially when a cache is being built on the fly, it can easily take a web service longer
than 60 seconds to complete a call with a mobile device. Surely this is indeed a bug and not
intentional?


was (Author: dougestey):
Can also confirm this bug. Timeout values (jQuery/Angular/vanilla XHRs, makes no difference)
are being completely ignored.

This is a huge problem if Apple is considering it to be expected behaviour. Especially when
a cache is being built on the fly, it can easily take a web service longer than 60 seconds
to complete a call with a mobile device. Surely iOS/Safari not respecting timeout values is
indeed a bug?

> Ajax call fails on iOS 10 but works fine on previous versions for Cordova application
> -------------------------------------------------------------------------------------
>
>                 Key: CB-11906
>                 URL: https://issues.apache.org/jira/browse/CB-11906
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: iOS
>         Environment: ios10
>            Reporter: Nikita Ahluwalia
>              Labels: ios10, ios10-known-issue
>
> I am using the latest iOS platform and plugins in my cordova application. The app works
fine on older versions of iOS but not on iOS 10. I am getting timeout error (I already have
timeout in my application. But this seems to be even before establishing connection with web
service). Tried removing platform and adding again. Also created a fresh project. Still no
luck. The app works fine on Android as well. The same application pointing to webservice on
staging environment works (on iOS 10 too) but when pointing to production APIs, it does not
work on iOS 10 but works on older version.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message