cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shazron Abdullah (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CB-12058) Document CocoaPods support in plugin.xml <framework> tag
Date Mon, 24 Oct 2016 22:32:59 GMT

     [ https://issues.apache.org/jira/browse/CB-12058?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Shazron Abdullah updated CB-12058:
----------------------------------
    Description: 
In plugin.xml <framework> tag.

i.e
{code}
<framework src="GoogleCloudMessaging" type="podspec" spec="~> 1.2.0"/>
{code}

Add these tags to ensure cli and platform support:
{code}
<engines>
  <engines>
    <engine name="cordova" version=">=6.4.0"/>
    <engine name="cordova-android" version=">=4.0.0"/>
    <engine name="cordova-ios" version=">=4.3.0"/>
  </engines>
{code}

Docs for your plugin:
{code}
Required cordova-cli version: 6.4.0
Required cordova-ios version: 4.3.0

Version XXX (and above) of this plugin supports CocoaPods installation of the YYY library.

If you are installing this plugin using npm, and you are using version 6.1.0 or greater of
the cordova-cli, it will automatically download the right version of this plugin for both
your platform and cli. If you are on a cordova-cli version less than 6.1.0, you will either
have to upgrade your cordova-cli version, or install the plugin explicitly by version.

If you are installing this plugin using a local file reference or a git url, you will have
to specify the version of this plugin explicitly as well if you don't fulfill the cordova-cli
and cordova-ios requirements.
{code}

  was:
In plugin.xml <framework> tag.

i.e
{code}
<framework src="GoogleCloudMessaging" type="podspec" spec="~> 1.2.0"/>
{code}


> Document CocoaPods support in plugin.xml <framework> tag
> --------------------------------------------------------
>
>                 Key: CB-12058
>                 URL: https://issues.apache.org/jira/browse/CB-12058
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Docs
>            Reporter: Shazron Abdullah
>            Assignee: Shazron Abdullah
>
> In plugin.xml <framework> tag.
> i.e
> {code}
> <framework src="GoogleCloudMessaging" type="podspec" spec="~> 1.2.0"/>
> {code}
> Add these tags to ensure cli and platform support:
> {code}
> <engines>
>   <engines>
>     <engine name="cordova" version=">=6.4.0"/>
>     <engine name="cordova-android" version=">=4.0.0"/>
>     <engine name="cordova-ios" version=">=4.3.0"/>
>   </engines>
> {code}
> Docs for your plugin:
> {code}
> Required cordova-cli version: 6.4.0
> Required cordova-ios version: 4.3.0
> Version XXX (and above) of this plugin supports CocoaPods installation of the YYY library.
> If you are installing this plugin using npm, and you are using version 6.1.0 or greater
of the cordova-cli, it will automatically download the right version of this plugin for both
your platform and cli. If you are on a cordova-cli version less than 6.1.0, you will either
have to upgrade your cordova-cli version, or install the plugin explicitly by version.
> If you are installing this plugin using a local file reference or a git url, you will
have to specify the version of this plugin explicitly as well if you don't fulfill the cordova-cli
and cordova-ios requirements.
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message