cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shazron Abdullah (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-11923) Glob library inside cordova is using minimatch@2.0.10
Date Wed, 28 Sep 2016 19:40:21 GMT

    [ https://issues.apache.org/jira/browse/CB-11923?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15530649#comment-15530649
] 

Shazron Abdullah commented on CB-11923:
---------------------------------------

Unfortunately browserify hasn't updated to glob-7 https://github.com/substack/node-browserify/pull/1602

> Glob library inside cordova is using  minimatch@2.0.10
> ------------------------------------------------------
>
>                 Key: CB-11923
>                 URL: https://issues.apache.org/jira/browse/CB-11923
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: CordovaJS
>    Affects Versions: 6.3.1
>            Reporter: Elie Obeid
>            Assignee: Shazron Abdullah
>            Priority: Critical
>
> Full description here
> http://stackoverflow.com/questions/39727130/npm-warn-deprecated-minimatch2-0-10-but-i-a-newer-version
> cordova-cli:
> {code}
> ├─┬ cordova-common@1.4.1
> │ └── minimatch@3.0.3
> └─┬ cordova-lib@6.4.0-nightly.2016.9.19.f8b58c78
>   ├─┬ cordova-js@4.1.4
>   │ └─┬ browserify@10.1.3
>   │   └─┬ glob@4.5.3
>   │     └── minimatch@2.0.10
>   └─┬ npm@2.15.11
>     └── minimatch@3.0.3
> {code}
> Looks like cordova-js has to update browserify -> glob -> minimatch



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message