cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shazron Abdullah (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CB-11811) Cocoapods error in cordova-lib tests
Date Tue, 06 Sep 2016 07:25:20 GMT
Shazron Abdullah created CB-11811:
-------------------------------------

             Summary: Cocoapods error in cordova-lib tests
                 Key: CB-11811
                 URL: https://issues.apache.org/jira/browse/CB-11811
             Project: Apache Cordova
          Issue Type: Bug
      Security Level: Public (Anyone can view this level - this is the default.)
            Reporter: Shazron Abdullah


{code}
Failures:

  1) cocoapod plugin add and rm end-to-end installs and uninstalls plugin depending on new
pod and existing pod
   Message:
     Expected 'CocoaPods was not found. Please install version 1.0.1 or greater from https://cocoapods.org/'
to be undefined.
   Stacktrace:
     Error: Expected 'CocoaPods was not found. Please install version 1.0.1 or greater from
https://cocoapods.org/' to be undefined.
    at /home/jenkins/jenkins-slave/workspace/cordova-nightly/cordova-lib/cordova-lib/spec-cordova/platform.spec.js:467:25
    at _rejected (/home/jenkins/jenkins-slave/workspace/cordova-nightly/cordova-lib/cordova-lib/node_modules/q/q.js:797:24)
    at /home/jenkins/jenkins-slave/workspace/cordova-nightly/cordova-lib/cordova-lib/node_modules/q/q.js:823:30
    at Promise.when (/home/jenkins/jenkins-slave/workspace/cordova-nightly/cordova-lib/cordova-lib/node_modules/q/q.js:1035:31)
    at Promise.promise.promiseDispatch (/home/jenkins/jenkins-slave/workspace/cordova-nightly/cordova-lib/cordova-lib/node_modules/q/q.js:741:41)
    at /home/jenkins/jenkins-slave/workspace/cordova-nightly/cordova-lib/cordova-lib/node_modules/q/q.js:557:44
    at flush (/home/jenkins/jenkins-slave/workspace/cordova-nightly/cordova-lib/cordova-lib/node_modules/q/q.js:108:17)
    at process._tickCallback (node.js:415:13)
{code}

The test is now invalid, since to properly install a CocoaPod dependency, cocoapods needs
to be installed. The implementation did not check for this before (thus it didn't fail), but
it does now.

There is no way to test this without CocoaPods being installed, all we can really test is
if the error message is correct.

To test e2e CocoaPods, we need to separate this test as an OS X only test, and run this test
on Travis CI only.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message