cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vladimir Kotikov (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CB-11663) <video> doesn't render MediaStream from getUserMedia
Date Tue, 16 Aug 2016 14:46:21 GMT

     [ https://issues.apache.org/jira/browse/CB-11663?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Vladimir Kotikov updated CB-11663:
----------------------------------
    Affects Version/s:     (was: 6.3.0)
                       5.2.0

> <video> doesn't render MediaStream from getUserMedia
> ----------------------------------------------------
>
>                 Key: CB-11663
>                 URL: https://issues.apache.org/jira/browse/CB-11663
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Android
>    Affects Versions: 5.2.0
>         Environment: Android 4.4-6.0, Crosswalk,
> Testing done mostly with Nexus6P, but run on some older devices too.
>            Reporter: Rafal Pastuszak
>            Priority: Critical
>              Labels: reproduced, triaged
>
> Previewing camera input in a video element using getUserMedia works perfectly fine in
Chrome, but breaks as soon as we open the same view within a cordova app.
> Added an example using Mozilla gUM polyfill here: https://s3-eu-west-1.amazonaws.com/rafal-temp/index.html
> (note that both new and deprecated gUM APIs don't work).
> This results in an empty, black <video> element. No errors are fired.
> Initially I thought, that this issue was related to AndroidManifest.xml permissions and
CSP, but fixing them makes no difference.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message