cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vladimir Kotikov (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (CB-11649) Unable to validate app through WACK built for store using Visual Studio 2015 for Windows 10 UWP
Date Thu, 11 Aug 2016 11:12:20 GMT

     [ https://issues.apache.org/jira/browse/CB-11649?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Vladimir Kotikov closed CB-11649.
---------------------------------
    Resolution: Invalid

> Unable to validate app through WACK built for store using Visual Studio 2015 for Windows
10 UWP
> -----------------------------------------------------------------------------------------------
>
>                 Key: CB-11649
>                 URL: https://issues.apache.org/jira/browse/CB-11649
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Windows
>    Affects Versions: 4.4.0, 4.3.2, 4.4.1, 4.4.2, 4.3.1
>         Environment: Windows 10 Pro x64 Build 1511 (586.494)
> Visual Studio 2015 Community Update 1
> Node JS 6.3.1 (x64)
> Cordova 6.3.0
> Windows Platform 4.4.2
>            Reporter: Lal Kishor
>            Assignee: Vladimir Kotikov
>            Priority: Critical
>              Labels: build, triaged, wfc, windows
>
> Create a blank cordova project:
>      cordova create dumbApp com.testing.dumbapp "Dumb App"
> Add windows platform to it:
>      cordova platform add windows
> Now open the CordovaApp.sln in Visual Studio 2015
>      Set windows 10 as startup project (I need to build for this only)
> Now if I run it on a windows 10 phone (Lumia 730) in debug mode it runs fine.
>    (App loads and "Device is Ready" message shows up)
> So now if I need to publish this app:
> I Right click on CordovaApp.Windows10(Universal Windows) -> Store -> Create App
Packages
> Select Yes in Build for Store.
> Click Next
> I Login with my store credentials.
> Select an app from the list & click Next
> on Select and Configure packages page:
>     Generate App Bundle -> always
>     I Select all (i.e- x86, x64, ARM) in architecture
> & then Create.
> Now, in Package Creation Completed window, it says Launch WACK on local machine. (Also
No appxupload file was created)
> Click Launch WACK.
> Select all tests (after admin privilege prompt & a cmd window)
> Click Next.
> & now the result shows as FAILED
> the Report shows following Error in Crashes and hangs:
> Application 3982*************.********_1.1.0.0_x64__0avdcyp53wg40 was detected by Windows
Error Reporting and experienced a crash or hang.
> That's a bare minimum application with no extra code, or plugin.
> This behavior is really bad, I had to pubish an app and this issue showed up with no
solution I am two weeks past the deadline.
> Guys developing windows platform please look through the issue and provide a fix.
> also, a workaround will be very helpful for my current project, if any.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message