cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adil Shaikh (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CB-11566) SplashScreen.java uses or overrides a deprecated API
Date Wed, 13 Jul 2016 06:37:20 GMT
Adil Shaikh created CB-11566:
--------------------------------

             Summary: SplashScreen.java uses or overrides a deprecated API
                 Key: CB-11566
                 URL: https://issues.apache.org/jira/browse/CB-11566
             Project: Apache Cordova
          Issue Type: Bug
          Components: CordovaJS, Plugin SplashScreen
    Affects Versions: 6.2.0
         Environment: jdk 1.8. 
Cordova 6.2.0
Android Device Version - 5.1.1
            Reporter: Adil Shaikh


Creating a new project with cordova.

Run it on android device.

Launches successfully with warning:

:CordovaLib:compileDebugJavaWithJavacNote: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.

Remove android platform from the project.

I add plugin cordova-plugin-splashscreen to my project.

Add android platform back to the project.

Launch in android device.

Launches successfully with a new warning along with the one above:

:compileDebugJavaWithJavacNote: E:\a Templates\cordovatemplate\platforms\android\src\org\apache\cordova\splashscreen\SplashScreen.java
uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.


Similar Issue I have reported to ionic which redirected me here:
https://github.com/driftyco/ionic/issues/7057





--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message