cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrej Zachar (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-10862) Cannot set minsdkversion
Date Thu, 14 Jul 2016 13:49:20 GMT

    [ https://issues.apache.org/jira/browse/CB-10862?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15376939#comment-15376939
] 

Andrej Zachar commented on CB-10862:
------------------------------------

I am having the same issue and I am using cordova 6.2.0.

config.xml
<widget ... >
 ...
  <preference name="android-minSdkVersion" value="21" />
  <preference name="android-targetSdkVersion" value="23" />
  ..
</widget>

But after cordova prepare or cordova build the AndroidManifest.xml is still containing this:

<uses-sdk android:minSdkVersion="16"android:targetSdkVersion="22" />

What I am doing wrong?

Best regards,
Andrej

> Cannot set minsdkversion
> ------------------------
>
>                 Key: CB-10862
>                 URL: https://issues.apache.org/jira/browse/CB-10862
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: CLI
>    Affects Versions: 5.1.1
>            Reporter: Sergey
>            Assignee: Sergey Shakhnazarov
>            Priority: Trivial
>              Labels: triaged
>
> used:
> cordova clean android
> cordova prepare android
> cordova build android --release --device --browserify --buildConfig=../resources/config.json
-- --gradleArg=-PcdvVersionCode=212 --gradleArg=-PcdvMinSdkVersion=21 --gradleArg=-PcdvCompileSdkVersion=android-23
> still produces minSdk 14+



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message