cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nikhil Khandelwal (JIRA)" <>
Subject [jira] [Updated] (CB-11097) Clicking hyperlink in an iframe opens a system browser instead of navigating to it
Date Mon, 18 Apr 2016 16:16:25 GMT


Nikhil Khandelwal updated CB-11097:
    Labels: ios triaged  (was: ios)

> Clicking hyperlink in an iframe opens a system browser instead of navigating to it
> ----------------------------------------------------------------------------------
>                 Key: CB-11097
>                 URL:
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: iOS, Plugin Whitelist
>    Affects Versions: 6.0.0, 6.1.1
>         Environment: Cordova 6.1.1, iOS platform 4.1.1, developing in Visual Studio 2015
with remote build server. Affects Cordova 6.0.0/iOS 4.0.0 and later. Same behaviour on simulator
and physical phone.
>            Reporter: Daniel Åberg
>              Labels: ios, triaged
> From Cordova 6.0.0/iOS platform 4.0.0 and newer there is a change in behavior or bug
that stops navigating an anchor tag/hyperlink to an external site from working.
> If you have an iframe with a page with an anchor tag in which an href that points to
for an external domain it will now open it in the system browser instead of loading it in
the iframe.
> It seems to have something to do how it handles if it’s going to navigate or open in
a new browser.
> If you have the this in your configuration file you get this behavior:
> <access origin="*" />
> <allow-navigation href="*" />  
> <allow-intent href="http://*/*" />
> <allow-intent href="https://*/*" />
> If the allow-intent tags are removed, the iframe will load the page in the href, so it
seems like it first checks the intents and if its allowed it is then opened in a new system
browser regardless of other configuration.
> This is a change in behavior, Cordova 5.4.1/iOS 3.9.2 navigated unless you used InAppBrowser with target _system to open in the system browser.
> I have tried this with and without having Whitelist and InAppBrowser plugins installed,
I also tried the Cordova WKWebView Engine and got the same behavior so I think it must be
something in the iOS platform.
> This issue might be related to the issue reported in CB-10709

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message