cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sam2x (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-11030) Since chrome v43 Weinre has multiple type error "illegal invocation" from target-script.js
Date Wed, 06 Apr 2016 18:37:25 GMT

    [ https://issues.apache.org/jira/browse/CB-11030?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15228854#comment-15228854
] 

Sam2x commented on CB-11030:
----------------------------

This issue was misleading, the error was coming from my instrumented code who get transmitted
to weinre and not from weinre code. To be more precise, the error was coming from a "watch"
block code that i cleared in favor of a "$scope.$on" event.

Sorry for the issue.

> Since chrome v43 Weinre has multiple type error "illegal invocation" from target-script.js
> ------------------------------------------------------------------------------------------
>
>                 Key: CB-11030
>                 URL: https://issues.apache.org/jira/browse/CB-11030
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: weinre
>            Reporter: Sam2x
>            Assignee: Patrick Mueller
>            Priority: Critical
>
> Weinre nodejs package: weinre@2.0.0-pre-I0Z7U9OV
> Npm version : 3.3.12
> Chrome version : 50.0.2661.18 dev (64-bit)
> Weinre is embedded is my angular project. The target-script.min.js is automatically injected
inside my html page for debug purpose. 
> Since Chrome v43, i stuck resolving recurrent loop error who get throwed in my debug
console  :
> angular.js:13424TypeError: Illegal invocation
>     at equals (angular.js:1077)
>     at equals (angular.js:1077)
>     at Scope.$digest (angular.js:16862)
>     at angular.js:17064
>     at completeOutstandingRequest (angular.js:5824)
>     at angular.js:6100
>     at instrumentedCode (target-script-min.js:3890)
> The incriminated code line is from the "InstrumentedCode" function which call "code.apply"
in line 3890 of ./node_modules/weinre/web/target/target-script-min.js: 
> result = code.apply(this, arguments);
> Am i the only one to get this recurrent error ? I would appreciate any helps.
> Downgrading version is not a solution for me. Thanks.
> Related issue : 
> https://github.com/angular/angular.js/issues/12004 https://bugs.chromium.org/p/chromium/issues/detail?id=167911
> http://stackoverflow.com/questions/30578722/typeerror-illegal-invocation-when-trying-to-upgrade-from-v1-2



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message