cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sergey Shakhnazarov (JIRA)" <>
Subject [jira] [Updated] (CB-11017) Long app load for iOS when using splashscreen
Date Tue, 05 Apr 2016 07:50:25 GMT


Sergey Shakhnazarov updated CB-11017:
    Labels: android ios loading performance screen splash splashscreen triaged wfc  (was:
android ios loading performance screen splash splashscreen)

> Long app load for iOS when using splashscreen
> ---------------------------------------------
>                 Key: CB-11017
>                 URL:
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Plugin SplashScreen
>    Affects Versions: 3.5.0
>            Reporter: Danbardo
>              Labels: android, ios, loading, performance, screen, splash, splashscreen,
triaged, wfc
> Hey,
> I've recently started using the cordova.splashscreen plugin and I have noticed it causes
very long loading times in iOS.
> When installing this plugin on my iOS application the loading time increased from 1 second
to sometimes over 10 seconds. I have tried a number of different configurations to try and
find the source of the problem with no success.
> My current, best performing, configuration is:
>  <preference name="AutoHideSplashScreen" value="false" />
> <preference name="SplashScreen" value="screen"/>
> <preference name="SplashScreenDelay" value="10000" />
> <preference name="FadeSplashScreen" value="true"/>
> <preference name="FadeSplashScreenDuration" value="500"/>
> and I have set a listener to run navigator.splashscreen.hide() on device load.
> With the same configuration on an Android device, the application takes around 1 second
to load, it shows the splash screen then hides when the application has loaded.
> I have noticed with iOS, when I load up the application it shows the splash screen, waits
maybe 4 seconds, then starts loading up the cordova application (I can see cordova plugins
being loaded in the debug window), waits another 6ish second then hides the splash screen.
> I have not been able to find any resolutions to this issue online.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message