cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Buijs (JIRA)" <j...@apache.org>
Subject [jira] [Reopened] (CB-10565) Unmet peer dependency
Date Wed, 20 Apr 2016 07:54:25 GMT

     [ https://issues.apache.org/jira/browse/CB-10565?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Alex Buijs reopened CB-10565:
-----------------------------

These are the steps to reproduce:
{code}
mkdir test && cd test
cat > package.json
{"private": true, "dependencies": {"cordova-plugin-file": "4.1.1", "cordova-plugin-media-capture":
"1.2.0"}}
ctrl-d
npm install
{code}
The output will be:
{code}
├── UNMET PEER DEPENDENCY cordova-plugin-file@4.1.1
└── cordova-plugin-media-capture@1.2.0

npm WARN cordova-plugin-media-capture@1.2.0 requires a peer of cordova-plugin-file@^3.0.0
but none was installed.
{code}
Which is quite obvious, since this plugin has the following line in it's package.json:
{code}
"peerDependencies": {
  "cordova-plugin-file": "^3.0.0"
}
{code}

> Unmet peer dependency
> ---------------------
>
>                 Key: CB-10565
>                 URL: https://issues.apache.org/jira/browse/CB-10565
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Plugin Media Capture
>            Reporter: Alex Buijs
>            Priority: Trivial
>              Labels: triaged, wfc
>
> Because the latest cordova-plugin-file is on 4.0.1, NPM emits this warning:
> {quote}
> npm WARN cordova-plugin-media-capture@1.2.0 requires a peer of cordova-plugin-file@^3.0.0
but none was installed.
> {quote}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message