cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-10510) medic-run doesn't check to make sure the emulator started
Date Tue, 16 Feb 2016 18:44:18 GMT

    [ https://issues.apache.org/jira/browse/CB-10510?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15149070#comment-15149070
] 

ASF GitHub Bot commented on CB-10510:
-------------------------------------

Github user riknoll commented on the pull request:

    https://github.com/apache/cordova-android/pull/258#issuecomment-184821410
  
    @omefire 


> medic-run doesn't check to make sure the emulator started
> ---------------------------------------------------------
>
>                 Key: CB-10510
>                 URL: https://issues.apache.org/jira/browse/CB-10510
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Medic
>         Environment: Windows, Android emulator
>            Reporter: Richard B Knoll
>            Assignee: Richard B Knoll
>              Labels: android, found-by-ci
>
> Medic doesn't check to see if the emulator actually starts when invoking {{cordova run
android}}. Instead, it starts polling cordova-vm immediately. This might also be considered
a bug in cordova-android's run script, which just seems to hang if the emulator doesn't start.
Example build is here:
> https://ci.apache.org/builders/cordova-android-win/builds/1488/steps/running-tests/logs/stdio
> And adb logs are here:
> https://ci.apache.org/builders/cordova-android-win/builds/1488/steps/gathering-logs/logs/stdio
> ====
> Log:
> C:\Users\buildbot\slaves\apache\cordova-android-win\mobilespec>node  C:\Users\buildbot\slaves\apache\cordova-android-win\cordova-cli\bin\cordova
run --emulator android -- --gradle 
> ANDROID_HOME=C:\Android\android-sdk
> JAVA_HOME=C:\Program Files (x86)\Java\jdk1.7.0_55
> No emulator specified, defaulting to Galaxy_Nexus
> Waiting for emulator...
> WARNING: init: Missing WGL extension WGL_ARB_make_current_read
> emulator: warning: opening audio output failed
> emulator: emulator window was out of view and was recentered
> emulator: UpdateChecker: skipped version check
> Booting up emulator (this may take a while)........................................query
failed for mobilespec_results { [Error: connect ETIMEDOUT] code: 'ETIMEDOUT', errno: 'ETIMEDOUT',
syscall: 'connect' }
> .....................................query failed for mobilespec_results { [Error: connect
ETIMEDOUT] code: 'ETIMEDOUT', errno: 'ETIMEDOUT', syscall: 'connect' }
> ..................query failed for mobilespec_results { [Error: connect ETIMEDOUT] code:
'ETIMEDOUT', errno: 'ETIMEDOUT', syscall: 'connect' }
> ....................................................................................................query
failed for mobilespec_results { [Error: connect ETIMEDOUT] code: 'ETIMEDOUT', errno: 'ETIMEDOUT',
syscall: 'connect' }
> ...................................................................................query
failed for mobilespec_results { [Error: connect ETIMEDOUT] code: 'ETIMEDOUT', errno: 'ETIMEDOUT',
syscall: 'connect' }
> .......................................................didn't get test results: timed
out
> program finished with exit code 1
> elapsedTime=1150.659000



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message