cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Miha Svalina (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CB-10427) npmconf and npm Deprecation warning
Date Mon, 25 Jan 2016 10:53:39 GMT

     [ https://issues.apache.org/jira/browse/CB-10427?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Miha Svalina updated CB-10427:
------------------------------
    Description: 
Application created using Visual Studio Cordova project.

My package.json content:

{code}
{
  "name": "TestCordovaApp",
  "version": "1.0.0",
  "private": true,
  "dependencies": {   
    "cordova-lib": "5.4.1",
    "cordova": "5.4.1"
  }
}
{code}

Other packages are not included, this is just for test. After running npm install command
in my project root directory the first two lines are:

{code}
X:\androidApp>npm install
npm WARN deprecated npmconf@2.1.2: this package has been reintegrated into npm and is now
out of date with respect to npm
npm WARN prefer global npm@2.14.16 should be installed with -g
TestCordovaApp@1.0.0 X:\androidApp
├─┬ cordova@5.4.1
│ ├── ansi@0.3.1
│ ├─┬ nopt@3.0.1
│ │ └── abbrev@1.0.7
│ ├── q@1.0.1
│ ├── underscore@1.7.0
│ └─┬ update-notifier@0.5.0
│   ├─┬ chalk@1.1.1
│   │ ├── ansi-styles@2.1.0
│   │ ├── escape-string-regexp@1.0.4
│   │ ├─┬ has-ansi@2.0.0
│   │ │ └── ansi-regex@2.0.0
│   │ ├── strip-ansi@3.0.0
│   │ └── supports-color@2.0.0
│   ├─┬ configstore@1.4.0
│   │ ├── graceful-fs@4.1.2{code}


I copied the whole cmd output to notepad++ and searched for string npmconf. It turns out that
cordova-lib 5.4.1 depends on npm 2.14.16.

{code}
├─┬ cordova-lib@5.4.1
│ ├─┬ npm@2.14.16
|    │ ├─┬ npmconf@2.1.2
{code}

I thought that if you are running npm > 2 that this won't be an issue. Or maybe I have
missed something to avoid seeing deprecation warning.

  was:
My package.json content:

{code}
{
  "name": "TestCordovaApp",
  "version": "1.0.0",
  "private": true,
  "dependencies": {   
    "cordova-lib": "5.4.1",
    "cordova": "5.4.1"
  }
}
{code}

Other packages are not included, this is just for test. After running npm install command
in my project root directory the first two lines are:

{code}
X:\androidApp>npm install
npm WARN deprecated npmconf@2.1.2: this package has been reintegrated into npm and is now
out of date with respect to npm
npm WARN prefer global npm@2.14.16 should be installed with -g
TestCordovaApp@1.0.0 X:\androidApp
├─┬ cordova@5.4.1
│ ├── ansi@0.3.1
│ ├─┬ nopt@3.0.1
│ │ └── abbrev@1.0.7
│ ├── q@1.0.1
│ ├── underscore@1.7.0
│ └─┬ update-notifier@0.5.0
│   ├─┬ chalk@1.1.1
│   │ ├── ansi-styles@2.1.0
│   │ ├── escape-string-regexp@1.0.4
│   │ ├─┬ has-ansi@2.0.0
│   │ │ └── ansi-regex@2.0.0
│   │ ├── strip-ansi@3.0.0
│   │ └── supports-color@2.0.0
│   ├─┬ configstore@1.4.0
│   │ ├── graceful-fs@4.1.2{code}


I copied the whole cmd output to notepad++ and searched for string npmconf. It turns out that
cordova-lib 5.4.1 depends on npm 2.14.16.

{code}
├─┬ cordova-lib@5.4.1
│ ├─┬ npm@2.14.16
|    │ ├─┬ npmconf@2.1.2
{code}

I thought that if you are running npm > 2 that this won't be an issue. Or maybe I have
missed something to avoid seeing deprecation warning.


> npmconf and npm Deprecation warning
> -----------------------------------
>
>                 Key: CB-10427
>                 URL: https://issues.apache.org/jira/browse/CB-10427
>             Project: Apache Cordova
>          Issue Type: Improvement
>          Components: Android, CordovaLib
>    Affects Versions: 5.4.1
>         Environment: - Microsoft Windows 10 x64
> - Microsoft Visual Studio 2015
> - Nodejs: 5.0.0 32-bit
> - npm 3.3.7 installed globally
>            Reporter: Miha Svalina
>
> Application created using Visual Studio Cordova project.
> My package.json content:
> {code}
> {
>   "name": "TestCordovaApp",
>   "version": "1.0.0",
>   "private": true,
>   "dependencies": {   
>     "cordova-lib": "5.4.1",
>     "cordova": "5.4.1"
>   }
> }
> {code}
> Other packages are not included, this is just for test. After running npm install command
in my project root directory the first two lines are:
> {code}
> X:\androidApp>npm install
> npm WARN deprecated npmconf@2.1.2: this package has been reintegrated into npm and is
now out of date with respect to npm
> npm WARN prefer global npm@2.14.16 should be installed with -g
> TestCordovaApp@1.0.0 X:\androidApp
> ├─┬ cordova@5.4.1
> │ ├── ansi@0.3.1
> │ ├─┬ nopt@3.0.1
> │ │ └── abbrev@1.0.7
> │ ├── q@1.0.1
> │ ├── underscore@1.7.0
> │ └─┬ update-notifier@0.5.0
> │   ├─┬ chalk@1.1.1
> │   │ ├── ansi-styles@2.1.0
> │   │ ├── escape-string-regexp@1.0.4
> │   │ ├─┬ has-ansi@2.0.0
> │   │ │ └── ansi-regex@2.0.0
> │   │ ├── strip-ansi@3.0.0
> │   │ └── supports-color@2.0.0
> │   ├─┬ configstore@1.4.0
> │   │ ├── graceful-fs@4.1.2{code}
> I copied the whole cmd output to notepad++ and searched for string npmconf. It turns
out that cordova-lib 5.4.1 depends on npm 2.14.16.
> {code}
> ├─┬ cordova-lib@5.4.1
> │ ├─┬ npm@2.14.16
> |    │ ├─┬ npmconf@2.1.2
> {code}
> I thought that if you are running npm > 2 that this won't be an issue. Or maybe I
have missed something to avoid seeing deprecation warning.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message