cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jagdish Adusumalli (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CB-10310) iOS Build fails after upgrade to cordova-ios@4.0.1
Date Fri, 08 Jan 2016 13:39:39 GMT
Jagdish Adusumalli created CB-10310:
---------------------------------------

             Summary: iOS Build fails after upgrade to cordova-ios@4.0.1
                 Key: CB-10310
                 URL: https://issues.apache.org/jira/browse/CB-10310
             Project: Apache Cordova
          Issue Type: Bug
          Components: iOS
         Environment: Cordova CLI: 5.4.1
Ionic Version: 1.2.1-nightly-1867
Ionic CLI Version: 1.7.12
Ionic App Lib Version: 0.6.5
ios-deploy version: 1.8.4
ios-sim version: 5.0.6
OS: Mac OS X El Capitan
Node Version: v5.4.0
Xcode version: Xcode 7.2 Build version 7C68

npm -v : 3.5.3
bower -v : 1.7.2
cordova platform :
Installed platforms: android 5.0.0, ios 4.0.1
Android tools and Platform-tools :
Pkg.Revision=24.4.1
Pkg.Revision=23.1
brew config :
HOMEBREW_VERSION: 0.9.5
CPU: quad-core 64-bit ivybridge
OS X: 10.11.2-x86_64
Xcode: 7.2
CLT: 7.2.0.0.1.1447826929
Clang: 7.0 build 700
X11: N/A
System Ruby: 2.0.0-p645
Perl: /usr/bin/perl
Python: /usr/local/bin/python => /usr/local/Cellar/python/2.7.11/Frameworks/Python.framework/Versions/2.7/bin/python2.7
Ruby: /Users/jagdish/.rbenv/shims/ruby => /Users/jagdish/.rbenv/versions/2.3.0/bin/ruby
Java: 1.8.0_66
psql --version: psql (PostgreSQL) 9.4.5
            Reporter: Jagdish Adusumalli


I'm working on an ionic app and just upgrade the ios platform to 4.0.1.

i am unable to build the ios app now using the command
"ionic build ios"

i observed the error is arising from the various plugins which are failing now.
i removed the plugins one after another to see how many plugins are incompatible and not working
and found the below 5 plugins are raising the same error

cordova-plugin-camera 1.2.0 "Camera"
cordova.plugins.diagnostic 2.3.5 "Diagnostic"
com.cordova.plugins.sms 0.1.6 "Cordova SMS Plugin"
com.dbaq.cordova.contactsPhoneNumbers 0.0.5 "Contacts Phone Numbers"
cordova-plugin-sms 1.0.5 "SMS"

Error sample raised for sms plugin looks as below
** BUILD FAILED **


The following build commands failed:
	CompileC build/qiddlestage.build/Debug-iphonesimulator/qiddlestage.build/Objects-normal/i386/Sms.o
qiddlestage/Plugins/com.cordova.plugins.sms/Sms.m normal i386 objective-c com.apple.compilers.llvm.clang.1_0.compiler
(1 failure)
ERROR building one of the platforms: Error code 65 for command: xcodebuild with args: -xcconfig,/Users/jagdish/work/ywt-moms/platforms/ios/cordova/build-debug.xcconfig,-project,qiddlestage.xcodeproj,ARCHS=i386,-target,qiddlestage,-configuration,Debug,-sdk,iphonesimulator,build,VALID_ARCHS=i386,CONFIGURATION_BUILD_DIR=/Users/jagdish/work/ywt-moms/platforms/ios/build/emulator,SHARED_PRECOMPS_DIR=/Users/jagdish/work/ywt-moms/platforms/ios/build/sharedpch
You may not have the required environment or OS to build this project
Error: Error code 65 for command: xcodebuild with args: -xcconfig,/Users/jagdish/work/ywt-moms/platforms/ios/cordova/build-debug.xcconfig,-project,qiddlestage.xcodeproj,ARCHS=i386,-target,qiddlestage,-configuration,Debug,-sdk,iphonesimulator,build,VALID_ARCHS=i386,CONFIGURATION_BUILD_DIR=/Users/jagdish/work/ywt-moms/platforms/ios/build/emulator,SHARED_PRECOMPS_DIR=/Users/jagdish/work/ywt-moms/platforms/ios/build/sharedpch

also attaching error screenshots with various plugins.





--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message