cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nikhil Khandelwal (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (CB-8344) Cannot run plugin cordova command with Node.js@0.11.15
Date Sat, 09 Jan 2016 01:17:39 GMT

     [ https://issues.apache.org/jira/browse/CB-8344?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Nikhil Khandelwal resolved CB-8344.
-----------------------------------
    Resolution: Not A Problem

> Cannot run plugin cordova command with Node.js@0.11.15
> ------------------------------------------------------
>
>                 Key: CB-8344
>                 URL: https://issues.apache.org/jira/browse/CB-8344
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: CordovaLib
>         Environment: OS: Ubuntu Linux 14.04 LTS/x64
> Node.js: 0.11.15
> npm: 2.1.6
>            Reporter: Tomo Masakura
>            Priority: Critical
>
> Cannot run plugin search cordova comand with Node.js 0.11.15.
> {quote}
> $ node --version
> v0.11.15
> $ cordova --version
> 4.2.0
> $ cordova create project1
> $ cd project1
> $ cordova platform add android
> $ cordova build
> $  ls platforms/android/ant-build/*.apk
> platforms/android/ant-build/CordovaApp-debug-unaligned.apk
> platforms/android/ant-build/CordovaApp-debug.apk
> {quote}
> Up to this point was operating normally.
> {quote}
> $ cordova plugin search camera
> Error: not_found missing: -/-/all
>     at RegClient.<anonymous> (/home/masakura/.nvm/v0.11.15/lib/node_modules/cordova/node_modules/cordova-lib/node_modules/npm/node_modules/npm-registry-client/lib/request.js:308:14)
>     at Request._callback (/home/masakura/.nvm/v0.11.15/lib/node_modules/cordova/node_modules/cordova-lib/node_modules/npm/node_modules/npm-registry-client/lib/request.js:246:65)
>     at Request.self.callback (/home/masakura/.nvm/v0.11.15/lib/node_modules/cordova/node_modules/cordova-lib/node_modules/npm/node_modules/request/request.js:236:22)
>     at Request.emit (events.js:110:17)
>     at Request.<anonymous> (/home/masakura/.nvm/v0.11.15/lib/node_modules/cordova/node_modules/cordova-lib/node_modules/npm/node_modules/request/request.js:1142:14)
>     at Request.emit (events.js:129:20)
>     at IncomingMessage.<anonymous> (/home/masakura/.nvm/v0.11.15/lib/node_modules/cordova/node_modules/cordova-lib/node_modules/npm/node_modules/request/request.js:1096:12)
>     at IncomingMessage.emit (events.js:129:20)
>     at _stream_readable.js:908:16
>     at process._tickCallback (node.js:355:11)
> {quote}
> Because that cordova-lib is using npm@1.4.28.
> Try, if I rewrite the package.json of cordova-lib to use the npm@2, was resolved.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message