cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christian Gelinek (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-10199) Android SDK Version in config.xml doesn't propagate to project.properties
Date Tue, 15 Dec 2015 22:48:46 GMT

    [ https://issues.apache.org/jira/browse/CB-10199?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15059038#comment-15059038
] 

Christian Gelinek commented on CB-10199:
----------------------------------------

Because I'd like to test my project on an Android 4.4 device. As far as I understand, that
means it has to be at least *compatible* (minSdkVersion) with API level 19. Because setting
minSdkVersion in my config.xml didn't change anything, I tried setting all (min, max and target)
to 19 just to see whether it helps. Since I am new to Android development, I might be wrong
with this. I noticed however that this (including other version combinations) seems to be
a common question, here some examples:
https://stackoverflow.com/q/30028483/897968
https://stackoverflow.com/q/27135185/897968
https://stackoverflow.com/q/30879502/897968

So unless it is (for whatever reason, please enlighten me) disallowed to choose an API level
other than dictated by the current cordova or cordova-android version, I think this is a bug.

> Android SDK Version in config.xml doesn't propagate to project.properties
> -------------------------------------------------------------------------
>
>                 Key: CB-10199
>                 URL: https://issues.apache.org/jira/browse/CB-10199
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Android
>         Environment: Xubuntu 14.04
>            Reporter: Christian Gelinek
>
> I couldn't find the versions I have in the entry form, here they are:
> {{cordova -v}}: 5.4.1
> {{cordova-android@4.1.1}}
> My config.xml file contains the following section:
> {noformat}
>     <platform name="android">
>         <preference name="android-minSdkVersion" value="19" />
>         <preference name="android-targetSdkVersion" value="19" />
>         <preference name="android-maxSdkVersion" value="19" />
>         <allow-intent href="market:*" />
>     </platform>
> {noformat}
> After running {{cordova platform add android}}, the _./platforms/android/AndroidManifest.xml_
file contains the line
> {{<uses-sdk android:maxSdkVersion="19" android:minSdkVersion="19" android:targetSdkVersion="19"
/>}}
> But the _./platforms/android/project.properties_ file still contains {{target=android-22}}.
> Therefore running e.g. {{cordova build android}} fails with the following message:
> {{ERROR: Error: Please install Android target: "android-22".}}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message