cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Philipp Kursawe (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-9847) Cannot tell when running on Simulator ( Windows )
Date Fri, 23 Oct 2015 22:54:27 GMT

    [ https://issues.apache.org/jira/browse/CB-9847?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14972029#comment-14972029
] 

Philipp Kursawe commented on CB-9847:
-------------------------------------

Not sure if we can find out if the app is running in the simulator under Windows. From the
code for android it looks like you just checking the build config options and nothing during
runtime actually?

> Cannot tell when running on Simulator ( Windows )
> -------------------------------------------------
>
>                 Key: CB-9847
>                 URL: https://issues.apache.org/jira/browse/CB-9847
>             Project: Apache Cordova
>          Issue Type: Improvement
>          Components: Plugin Device
>            Reporter: Jesse MacFadyen
>            Assignee: Jesse MacFadyen
>            Priority: Minor
>              Labels: Windows, triaged
>
> There are times where things simply won't work when we are running on the simulator.
 For example, if you are using the device-motion api you will simply never receive a result
when calling `getCurrentAcceleration`
> It would be nice if we could tell before the call if this is the case, and avoid waiting
for a result.
> Prior art in https://github.com/apache/cordova-plugin-device/pull/35



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message