cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sergey Shakhnazarov (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (CB-5198) Plugins with dependency's will fail with cordova 3.0
Date Tue, 27 Oct 2015 08:31:27 GMT

     [ https://issues.apache.org/jira/browse/CB-5198?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Sergey Shakhnazarov resolved CB-5198.
-------------------------------------
    Resolution: Invalid

> Plugins with dependency's will fail with cordova 3.0
> ----------------------------------------------------
>
>                 Key: CB-5198
>                 URL: https://issues.apache.org/jira/browse/CB-5198
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Plugin File Transfer, Plugin Media Capture
>    Affects Versions: 3.0.0
>            Reporter: Steve Gill
>             Fix For: 3.6.0
>
>
> The two plugins above have a dependency tag that downloads from the registry. 
> Cordova 3.0.0 doesn't have support for downloading from the registry. 
> If someone with cordova 3.0.0 installs the file-transfer plugin (using the git url since
that was the suggested way for 3.0), it will fail in installing the dependency due to lack
of registry support.
> Suggestions
> Bump the major version of these plugins and set engine tag to 3.1.0
> Change 3.0 docs to suggest downloading based of 3.0.0 tag instead of from master. Ex.
cordova plugin add https://git-wip-us.apache.org/repos/asf/cordova-plugin-file-transfer.git#3.0.0
(I am having trouble with this right now, figuring out why)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message