cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vladimir Kotikov (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (CB-9291) Cordova NPM package does not install when Node >= 0.12.x
Date Wed, 15 Jul 2015 12:47:04 GMT

    [ https://issues.apache.org/jira/browse/CB-9291?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14627993#comment-14627993
] 

Vladimir Kotikov edited comment on CB-9291 at 7/15/15 12:46 PM:
----------------------------------------------------------------

I didn't found any reason for that. Especially due to fact that {{engines}} option in package.json
doesn't actually restrict Node version (see https://docs.npmjs.com/files/package.json#engines),
until {{engineStrict}} option is not specified (and it isn't).

So the only consequence of {{engines}} presense - the warning message, as shown in the report
{noformat}
npm WARN engine cordova-js@4.0.0: wanted: {"node":"~0.10.x"} (current: {"node":"0.12.6","npm":"2.11.2"})
{noformat}

Anyway it looks confusing, so probably we may remove {{engines}} totally or make it less strict.
E.g. {{node >= 0.10.x}}


was (Author: vladimir.kotikov):
I didn't found any reason for that. Especially due to fact that {{engines}} option in package.json
doesn't actually restrict Node version (see https://docs.npmjs.com/files/package.json#engines),
until {{engineStrict}} option is not specified (and it isn't).

So the only consequence of {{engines}} presense - the warning message, as shown in the report
{noformat}
npm WARN engine cordova-js@4.0.0: wanted: {"node":"~0.10.x"} (current: {"node":"0.12.6","npm":"2.11.2"})
{noformat}

Anyway it looks confusing, so probably we may remove {{engines}} totally or make it less strict.
E.g. {{node >= 0.10.x}}

> Cordova NPM package does not install when Node >= 0.12.x
> --------------------------------------------------------
>
>                 Key: CB-9291
>                 URL: https://issues.apache.org/jira/browse/CB-9291
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: CordovaJS
>    Affects Versions: 4.0.0
>         Environment: Windows7 x64 with NodeJS 0.12.6
>            Reporter: Robert
>            Assignee: Vladimir Kotikov
>            Priority: Critical
>
> Hi
> I am trying to install cordova in version 5.1.1 (also tried some previous versions) using
node 0.12.6:
> npm cache clean dep-graph
> npm install -g cordova@5.1.1
> Unfortunately, cordova-js depends on an older version of node (~0.10.x) which seems the
reason for cordova not being installable:
> {noformat}
> >npm install -g cordova@5.1.1
> npm WARN engine cordova-js@4.0.0: wanted: {"node":"~0.10.x"} (current: {"node":"0.12.6","npm":"2.11.2"})
> npm WARN engine npm@1.3.4: wanted: {"node":">=0.6","npm":"1"} (current: {"node":"0.12.6","npm":"2.11.2"})
> npm WARN engine xmlbuilder@2.2.1: wanted: {"node":"0.8.x || 0.10.x"} (current: {"node":"0.12.6","npm":"2.11.2"})
> npm WARN installMany normalize-package-data was bundled with npm@1.3.4, but bundled package
wasn't found in unpacked tree
> C:\Users\robert\AppData\Roaming\npm\cordova -> C:\Users\robert\AppData\Roaming\npm\node_modules\cordova\bin\cordova
> cordova@5.1.1 C:\Users\robert\AppData\Roaming\npm\node_modules\cordova
> ├── underscore@1.7.0
> ├── q@1.0.1
> ├── nopt@3.0.1 (abbrev@1.0.7)
> └── cordova-lib@5.1.1 (valid-identifier@0.0.1, osenv@0.1.0, properties-parser@0.2.3,
bplist-parser@0.0.6, mime@1.2.11, unorm@1.3.3, semver@2.1.0, rc@0.5.2, shelljs@0.3.0, dep-graph@1.1.0,
through2@0.6.3, npmconf@0.1.16, xcode@0.6.7, d8@0.4.4, init-package-json@1.7.0, elementtree@0.1.6,
request@2.47.0, glob@4.0.6, cordova-registry-mapper@1.1.8, tar@1.0.2, cordova-app-hello-world@3.9.0,
cordova-js@4.0.0, plist@1.1.0, npm@1.3.4)
> {noformat}
> Thanks in advance.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message