cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Trevor Best (JIRA)" <>
Subject [jira] [Commented] (CB-7281) "cordova plugin add" issues nonsense EACCESS error
Date Wed, 08 Jul 2015 08:08:04 GMT


Trevor Best commented on CB-7281:

The ~/.npm directory is owned by root so the command:

$ sudo chmod 777 ~/.npm

Will enable you to continue without having to sudo each time.

> "cordova plugin add" issues nonsense EACCESS error
> --------------------------------------------------
>                 Key: CB-7281
>                 URL:
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Plugins
>         Environment: ubuntu 14.04
>            Reporter: teo
> On a freshly created test application targeted at android, which works fine.
> I ran:
> $ cordova plugin add nl.sylvain.cordova.osc
> Fetching plugin "nl.sylvain.cordova.osc" via plugin registry
> Error: EACCES, mkdir '/home/teo/tmp/npm-20870-r97koGWy'
> That doesn't make sense, as /home/teo is my home directory (I was running the above command
as "teo"). There's no reason why that mkdir command should get an access denied error (if
that's what EACCESS means).
> This worked:
> $ sudo cordova plugin add nl.sylvain.cordova.osc
> however, there's no reason why sudo should be needed.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message