cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joe Bowser (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (CB-9216) Cordova 5 Throws Errors When Handling Push Notifications From Bluemix on Android 22
Date Thu, 18 Jun 2015 17:04:01 GMT

     [ https://issues.apache.org/jira/browse/CB-9216?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Joe Bowser resolved CB-9216.
----------------------------
    Resolution: Won't Fix

This is not a problem with Cordova, this is a problem with the plugin.  In Cordova-Android
4.0, which is distributed with Android 5.0, we removed sendJavascript(), and all callbacks
need to be sent using the callback system provided by Cordova.  This plugin is incompatible
and needs to be upgraded.  That's why this is throwing errors.

> Cordova 5 Throws Errors When Handling Push Notifications From Bluemix on Android 22
> -----------------------------------------------------------------------------------
>
>                 Key: CB-9216
>                 URL: https://issues.apache.org/jira/browse/CB-9216
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Android, Plugins
>    Affects Versions: 5.0.1, 5.0.0, 5.2, 5.1.2, 5.1.2, 5.2.0
>         Environment: Android 22 and above using cordova 5.0 and above and Bluemix Push
Plugin
>            Reporter: David Robert Cariello
>            Priority: Blocker
>   Original Estimate: 72h
>  Remaining Estimate: 72h
>
> Once I upgraded to Cordova 5 and above I saw issues handling push notifications from
Bluemix only on Android. You can find my initial conversation here https://developer.ibm.com/answers/questions/179382/is-ibmpush-plugin-compatible-with-cordova-4.html
where I was unable to reproduce the problem (I'm sure I was missing something). However, I
later confirmed the issue with 5.0 which you can test using this sample https://hub.jazz.net/project/ldeluca/bluemixpush/overview
. The error is always just like this https://gist.github.com/DaniloOliveira28/44a4e6e00825ac7b313e
> NOTE: I did not test on lower versions of Cordova while using Android API 22, couldn't
figure it out, but I confirmed the default versions worked fine below Cordova 5.0.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message