cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CB-9212) Plugin install via git url error "cross-device link not permitted"
Date Thu, 18 Jun 2015 03:01:00 GMT
Michael created CB-9212:
---------------------------

             Summary: Plugin install via git url error "cross-device link not permitted"
                 Key: CB-9212
                 URL: https://issues.apache.org/jira/browse/CB-9212
             Project: Apache Cordova
          Issue Type: Bug
         Environment: Windows
            Reporter: Michael


After upgrading from Cordova 5.0.0 to 5.1.1 on Windows I now get this error when installing
plugins from a Git url:

{code:none}
Repository "https://github.com/Telerik-Verified-Plugins/PushNotification.git" checked out
to git ref "master".
shell.js: internal error
Error: EXDEV, cross-device link not permitted 'C:\Users\MCMCDO~1\AppData\Local\Temp\git\1434595972863\Example'
    at Error (native)
    at Object.fs.renameSync (fs.js:636:18)
    at C:\Users\mcmcdonald\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\node_modules\shelljs\src\mv.js:77:8
    at Array.forEach (native)
    at Object._mv (C:\Users\mcmcdonald\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\node_modules\shelljs\src\mv.js:53:11)
    at Object.mv (C:\Users\mcmcdonald\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\node_modules\shelljs\src\common.js:186:23)
    at C:\Users\mcmcdonald\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\plugman\util\plugins.js:53:19
    at _fulfilled (C:\Users\mcmcdonald\AppData\Roaming\npm\node_modules\cordova\node_modules\q\q.js:787:54)
    at self.promiseDispatch.done (C:\Users\mcmcdonald\AppData\Roaming\npm\node_modules\cordova\node_modules\q\q.js:816:30)
    at Promise.promise.promiseDispatch (C:\Users\mcmcdonald\AppData\Roaming\npm\node_modules\cordova\node_modules\q\q.js:749:13)
{code}

Some others who have experienced this error:
http://stackoverflow.com/q/30801307/222748

Note you're missing 5.1.1 in the list of available versions in "Affects Version/s" field when
filing this bug.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message