cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nikhil Khandelwal (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (CB-9147) Adding a platform with a caret version adds the very latest rather than the latest matching version
Date Mon, 29 Jun 2015 17:37:05 GMT

     [ https://issues.apache.org/jira/browse/CB-9147?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Nikhil Khandelwal resolved CB-9147.
-----------------------------------
    Resolution: Fixed

> Adding a platform with a caret version adds the very latest rather than the latest matching
version
> ---------------------------------------------------------------------------------------------------
>
>                 Key: CB-9147
>                 URL: https://issues.apache.org/jira/browse/CB-9147
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: CordovaLib
>    Affects Versions: 5.0.0
>            Reporter: Tim Barham
>            Assignee: Tim Barham
>
> If you add, say, windows 3.5.0 platform to a project with the save flag:
> {noformat}
> cordova platform add windows@3.5.0 --save
> {noformat}
> We write out {{^3.5.0}} to {{config.xml}}.
> If the platform is removed then re-added, we install {{4.0.0}} instead of the expected
{{3.8.2}}.
> This is because internally we are using a version of {{npm}} that doesn't understand
caret versions.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message