cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "clemclim (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-8621) Error: Cannot find module 'Q'
Date Wed, 10 Jun 2015 08:23:01 GMT

    [ https://issues.apache.org/jira/browse/CB-8621?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14580212#comment-14580212
] 

clemclim commented on CB-8621:
------------------------------

Yes it works for ios, but for windows phone the problem is still not solved (Q instead of
q). If you compile from linux or macos the same error happen.

Please patch the problem, because I don't know how to do it ... each time I make a "phonegap
platform add wp8" it re-download the original wrong javascript for windows phone... 

It's not that I like windows, but I have to build it on this system Guys... :/ Thanks

> Error: Cannot find module 'Q'
> -----------------------------
>
>                 Key: CB-8621
>                 URL: https://issues.apache.org/jira/browse/CB-8621
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: iOS
>         Environment: Mac OSX Yosemite 10.10.1
>            Reporter: Marco
>             Fix For: 4.0.0
>
>         Attachments: CB-8621.patch
>
>
> After upgrading Cordova-CLI to the last version (4.3.0), when i run: "cordova build"
i get the following error:
> module.js:340
>     throw err;
>           ^
> Error: Cannot find module 'Q'
>     at Function.Module._resolveFilename (module.js:338:15)
>     at Function.Module._load (module.js:280:25)
>     at Module.require (module.js:364:17)
>     at require (module.js:380:17)
>     at Object.<anonymous> (/Volumes/CaseSensitive/ios_projects/_Tests/testGruntCordova/testGruntCordova/platforms/ios/cordova/lib/check_reqs.js:25:13)
>     at Module._compile (module.js:456:26)
>     at Object.Module._extensions..js (module.js:474:10)
>     at Module.load (module.js:356:32)
>     at Function.Module._load (module.js:312:12)
>     at Module.require (module.js:364:17)
> ERROR building one of the platforms: Error: /Volumes/CaseSensitive/ios_projects/_Tests/testGruntCordova/testGruntCordova/platforms/ios/cordova/build:
Command failed with exit code 8
> You may not have the required environment or OS to build this project
> Error: /Volumes/CaseSensitive/ios_projects/_Tests/testGruntCordova/testGruntCordova/platforms/ios/cordova/build:
Command failed with exit code 8
>     at ChildProcess.whenDone (/usr/local/lib/node_modules/cordova/node_modules/cordova-lib/src/cordova/superspawn.js:131:23)
>     at ChildProcess.EventEmitter.emit (events.js:98:17)
>     at maybeClose (child_process.js:753:16)
>     at Process.ChildProcess._handle.onexit (child_process.js:820:5)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message