cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Gill (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-8683) Update package.id to package.name for all core plugins
Date Sat, 28 Mar 2015 00:21:54 GMT

    [ https://issues.apache.org/jira/browse/CB-8683?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14384958#comment-14384958
] 

Steve Gill commented on CB-8683:
--------------------------------

Question: What exactly should I be renaming here?

cordova-plugin-battery-status
grep -R "org.apache.cordova" *
README.md:[![Build Status](https://travis-ci.org/apache/cordova-plugin-battery-status.svg)](https://travis-ci.org/apache/cordova-plugin-battery-status)
RELEASENOTES.md:* CB-4889 renaming org.apache.cordova.core.battery-status to org.apache.cordova.battery-status
doc/de/index.md:    cordova plugin add org.apache.cordova.battery-status
doc/es/index.md:# org.apache.cordova.battery-status
doc/es/index.md:    cordova plugin add org.apache.cordova.battery-status
doc/fr/index.md:    cordova plugin add org.apache.cordova.battery-status
doc/it/index.md:    cordova plugin add org.apache.cordova.battery-status
doc/ja/index.md:# org.apache.cordova.battery ステータス
doc/ja/index.md:    cordova plugin add org.apache.cordova.battery-status
doc/ko/index.md:# org.apache.cordova.battery 상태
<?xml version="1.0" encoding="UTF-8"?>
doc/ko/index.md:    cordova plugin add org.apache.cordova.battery-status
doc/pl/index.md:    cordova plugin add org.apache.cordova.battery-status
doc/ru/index.md:# org.apache.cordova.battery-status
doc/ru/index.md:    cordova plugin add org.apache.cordova.battery-status
doc/zh/index.md:# org.apache.cordova.battery-地位
doc/zh/index.md:    cordova plugin add org.apache.cordova.battery-status
package.json:    "id": "org.apache.cordova.battery-status",
plugin.xml:      id="org.apache.cordova.battery-status"
plugin.xml:                <param name="android-package" value="org.apache.cordova.batterystatus.BatteryListener"/>
plugin.xml:        <source-file src="src/android/BatteryListener.java" target-dir="src/org/apache/cordova/batterystatus"
/>
plugin.xml:                <param name="android-package" value="org.apache.cordova.batterystatus.BatteryListener"/>
plugin.xml:        <source-file src="src/android/BatteryListener.java" target-dir="src/org/apache/cordova/batterystatus"
/>
src/android/BatteryListener.java:package org.apache.cordova.batterystatus;
src/android/BatteryListener.java:import org.apache.cordova.CallbackContext;
src/android/BatteryListener.java:import org.apache.cordova.CordovaPlugin;
src/android/BatteryListener.java:import org.apache.cordova.PluginResult;
tests/plugin.xml:    id="org.apache.cordova.battery-status.tests"

I'm thinking I change:
* id in plugin.xml to cordova-plugin-battery-status
* id in package.json to cordova-plugin-battery-status (same as package-name)
* tests/plugin.xml id to cordova-plugin-battery-status-tests (will this cause other problems?)


I'm thinking I leave the rest alone. 

Thoughts? [~agrieve][~mmocny][~iclelland]



> Update package.id to package.name for all core plugins
> ------------------------------------------------------
>
>                 Key: CB-8683
>                 URL: https://issues.apache.org/jira/browse/CB-8683
>             Project: Apache Cordova
>          Issue Type: Sub-task
>          Components: Plugins
>            Reporter: Steve Gill
>            Assignee: Steve Gill
>
> We are changing the plugin ids to match plugin name



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message