cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Tamony (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CB-8338) Version? Updates? Etc....
Date Wed, 21 Jan 2015 18:51:34 GMT
Michael Tamony created CB-8338:
----------------------------------

             Summary: Version? Updates? Etc....
                 Key: CB-8338
                 URL: https://issues.apache.org/jira/browse/CB-8338
             Project: Apache Cordova
          Issue Type: Bug
          Components: CordovaLib
            Reporter: Michael Tamony


I am baffled and maybe this isn't considered a bug, but some updated docs on Cordova would
be sweet. When I update to the latest Cordova I see 
cordova -v
4.2.0
In here 3.5 is the latest.

I performed an update and had a bunch of errors:
sudo npm update -g cordova
Password:
npm WARN engine ncallbacks@1.0.0: wanted: {"node":"~0.6.7"} (current: {"node":"0.10.32","npm":"1.4.28"})
npm WARN package.json github-url-from-git@1.1.1 No repository field.
/usr/local/bin/cordova -> /usr/local/lib/node_modules/cordova/bin/cordova
npm WARN unmet dependency /usr/local/lib/node_modules/phonegap/node_modules/cordova/node_modules/plugman/node_modules/npm/node_modules/fstream
requires rimraf@'2' but will load
npm WARN unmet dependency undefined,
npm WARN unmet dependency which is version undefined
npm WARN unmet dependency /usr/local/lib/node_modules/phonegap/node_modules/cordova/node_modules/plugman/node_modules/npm/node_modules/node-gyp
requires rimraf@'2' but will load
npm WARN unmet dependency undefined,
npm WARN unmet dependency which is version undefined
npm WARN unmet dependency /usr/local/lib/node_modules/phonegap/node_modules/cordova/node_modules/plugman/node_modules/npm/node_modules/node-gyp
requires which@'1' but will load
npm WARN unmet dependency undefined,
npm WARN unmet dependency which is version undefined
npm WARN unmet dependency /usr/local/lib/node_modules/phonegap/node_modules/cordova/node_modules/plugman/node_modules/npm/node_modules/npm-registry-client
requires slide@'~1.1.3' but will load
npm WARN unmet dependency undefined,
npm WARN unmet dependency which is version undefined
npm WARN unmet dependency /usr/local/lib/node_modules/phonegap/node_modules/cordova/node_modules/plugman/node_modules/npm/node_modules/npm-registry-client
requires rimraf@'~2' but will load
npm WARN unmet dependency undefined,
npm WARN unmet dependency which is version undefined
npm WARN unmet dependency /usr/local/lib/node_modules/phonegap/node_modules/cordova/node_modules/plugman/node_modules/npm/node_modules/npm-registry-client
requires retry@'0.6.0' but will load
npm WARN unmet dependency undefined,
npm WARN unmet dependency which is version undefined
npm WARN unmet dependency /usr/local/lib/node_modules/phonegap/node_modules/cordova/node_modules/plugman/node_modules/npm/node_modules/read-installed
requires slide@'~1.1.3' but will load
npm WARN unmet dependency undefined,
npm WARN unmet dependency which is version undefined

Looked around in Stackoverflow and thought this would fix things:
 npm install npm -g

Now my CLI is doing nothing:
 sudo npm update -g cordova
Password:
sudo: npm: command not found



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message