cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Soref (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CB-8276) platform name is buried in output
Date Thu, 08 Jan 2015 16:55:35 GMT
Josh Soref created CB-8276:
------------------------------

             Summary: platform name is buried in output
                 Key: CB-8276
                 URL: https://issues.apache.org/jira/browse/CB-8276
             Project: Apache Cordova
          Issue Type: Bug
          Components: Plugman
            Reporter: Josh Soref


So, I have a project, with some platforms:

{quote}
$ cordova platforms
{quote}

{quote}
Installed platforms: android 3.4.0, blackberry10 3.5.0, ios 3.4.0
Available platforms: amazon-fireos, browser, firefoxos
{quote}

And there's a bug CB-8218 which suggested installing the facebook plugin:

{quote}
$ cordova plugin add ~/Cordova/phonegap-facebook-plugin  --variable APP_ID=616451688482285
--variable APP_NAME="hybrid-app" \[14:17:00]
{quote}

{quote}
Installing "com.phonegap.plugins.facebookconnect" for android
Failed to install 'com.phonegap.plugins.facebookconnect':CordovaError: Plugin doesn't support
this project's cordova version. cordova: 3.4.0, failed version requirement: >=3.5.0
    at checkEngines (cordova-lib/src/plugman/install.js:116:29)
    at _fulfilled (cordova-lib/node_modules/q/q.js:787:54)
    at self.promiseDispatch.done (cordova-lib/node_modules/q/q.js:816:30)
    at Promise.promise.promiseDispatch (cordova-lib/node_modules/q/q.js:749:13)
    at cordova-lib/node_modules/q/q.js:557:44
    at flush (cordova-lib/node_modules/q/q.js:108:17)
    at process._tickCallback (node.js:415:13)
Plugin doesn't support this project's cordova version. cordova: 3.4.0, failed version requirement:
>=3.5.0
{quote}

_this project_ doesn't mean anything to me, the user. It might benefit from a path. It probably
would benefit from repeating the name of the cordova platform, since really, the last line
is the line I want to read.

Either that, or the stack trace should be eaten, because if all I saw was:
{quote}
Installing "com.phonegap.plugins.facebookconnect" for android
Failed to install 'com.phonegap.plugins.facebookconnect':CordovaError: Plugin doesn't support
this project's cordova version. cordova: 3.4.0, failed version requirement: >=3.5.0
{quote}

I might be able to figure out that *android* is the important piece of information.

Also, It would really help if the error explained "how to fix the problem"

i.e.
{quote}
cordova platform update android
{quote}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message