cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ruoyu Fu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-8270) Objective-C methods on categories should be named with a prefix
Date Thu, 08 Jan 2015 04:11:34 GMT

    [ https://issues.apache.org/jira/browse/CB-8270?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14268797#comment-14268797
] 

Ruoyu Fu commented on CB-8270:
------------------------------

Actually, it clashes with the TencentOpenAPI framework which is a major sns platform in China

> Objective-C methods on categories should be named with a prefix
> ---------------------------------------------------------------
>
>                 Key: CB-8270
>                 URL: https://issues.apache.org/jira/browse/CB-8270
>             Project: Apache Cordova
>          Issue Type: Improvement
>          Components: iOS
>    Affects Versions: Master
>         Environment: All iOS platforms
>            Reporter: Ruoyu Fu
>            Priority: Critical
>              Labels: categories, ios, namespace
>             Fix For: Master
>
>   Original Estimate: 168h
>  Remaining Estimate: 168h
>
> According to Apple's documentation, naming a Category method without a prefix would possibly
cause a Name Clash
> https://developer.apple.com/library/ios/documentation/Cocoa/Conceptual/ProgrammingWithObjectiveC/CustomizingExistingClasses/CustomizingExistingClasses.html#//apple_ref/doc/uid/TP40011210-CH6-SW4
> In CordovaLib/Classes/CDVJSON.h : NSArray(CDVJSONSerializing) 
> The method name should starts with a prefix



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message