cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Soref (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CB-8124) npm-link does not seem to work
Date Fri, 05 Dec 2014 00:58:14 GMT

     [ https://issues.apache.org/jira/browse/CB-8124?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Josh Soref updated CB-8124:
---------------------------
    Assignee: Marcel Kinard

> npm-link does not seem to work
> ------------------------------
>
>                 Key: CB-8124
>                 URL: https://issues.apache.org/jira/browse/CB-8124
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Coho, mobile-spec
>            Reporter: Josh Soref
>            Assignee: Marcel Kinard
>            Priority: Critical
>
> {quote}
> ~/Cordova $ cordova-coho/coho npm-link
> Running from ~/Cordova
> npm-linking dependent modules
> ~/Cordova/cordova-js ~/Cordova
> npm WARN prefer global grunt-cli@0.1.13 should be installed with -g
> ~/npm/lib/node_modules/cordova-js -> ~/Cordova/cordova-js
> ~/Cordova
> ~/Cordova/cordova-lib/cordova-lib ~/Cordova
> unbuild cordova-js@3.7.2
> ~/Cordova
> ~/Cordova/cordova-lib/cordova-lib ~/Cordova
> npm http GET https://registry.npmjs.org/cordova-js/3.7.2
> npm http 304 https://registry.npmjs.org/cordova-js/3.7.2
> npm http GET https://registry.npmjs.org/uglify-js/2.4.15
> npm http GET https://registry.npmjs.org/browserify/3.46.0
> npm http GET https://registry.npmjs.org/through/2.3.4
> npm http 304 https://registry.npmjs.org/uglify-js/2.4.15
> npm http 304 https://registry.npmjs.org/browserify/3.46.0
> npm http 304 https://registry.npmjs.org/through/2.3.4
> npm http GET https://registry.npmjs.org/async
> npm http GET https://registry.npmjs.org/source-map/0.1.34
> npm http GET https://registry.npmjs.org/optimist
> npm http GET https://registry.npmjs.org/uglify-to-browserify
> npm http 304 https://registry.npmjs.org/async
> npm http 304 https://registry.npmjs.org/source-map/0.1.34
> npm http 304 https://registry.npmjs.org/optimist
> npm http 304 https://registry.npmjs.org/uglify-to-browserify
> npm http GET https://registry.npmjs.org/JSONStream
> npm http GET https://registry.npmjs.org/assert
> npm http GET https://registry.npmjs.org/browser-pack
> npm http GET https://registry.npmjs.org/browser-resolve
> npm http GET https://registry.npmjs.org/browserify-zlib
> npm http GET https://registry.npmjs.org/buffer
> npm http GET https://registry.npmjs.org/builtins
> npm http GET https://registry.npmjs.org/commondir/0.0.1
> npm http GET https://registry.npmjs.org/concat-stream
> npm http GET https://registry.npmjs.org/console-browserify
> npm http GET https://registry.npmjs.org/constants-browserify
> npm http GET https://registry.npmjs.org/crypto-browserify
> npm http GET https://registry.npmjs.org/deep-equal
> npm http GET https://registry.npmjs.org/defined
> npm http GET https://registry.npmjs.org/deps-sort
> npm http GET https://registry.npmjs.org/derequire
> npm http GET https://registry.npmjs.org/domain-browser
> npm http GET https://registry.npmjs.org/duplexer
> npm http GET https://registry.npmjs.org/events
> npm http GET https://registry.npmjs.org/glob
> npm http GET https://registry.npmjs.org/http-browserify
> npm http GET https://registry.npmjs.org/https-browserify
> npm http GET https://registry.npmjs.org/inherits
> npm http GET https://registry.npmjs.org/insert-module-globals
> npm http GET https://registry.npmjs.org/module-deps
> npm http GET https://registry.npmjs.org/os-browserify
> npm http GET https://registry.npmjs.org/parents
> npm http GET https://registry.npmjs.org/path-browserify
> npm http GET https://registry.npmjs.org/punycode
> npm http GET https://registry.npmjs.org/querystring-es3/0.2.0
> npm http GET https://registry.npmjs.org/resolve
> npm http GET https://registry.npmjs.org/shallow-copy/0.0.1
> npm http GET https://registry.npmjs.org/shell-quote
> npm http GET https://registry.npmjs.org/stream-browserify
> npm http GET https://registry.npmjs.org/stream-combiner
> npm http GET https://registry.npmjs.org/string_decoder
> npm http GET https://registry.npmjs.org/subarg/0.0.1
> npm http GET https://registry.npmjs.org/syntax-error
> npm http GET https://registry.npmjs.org/through2
> npm http GET https://registry.npmjs.org/timers-browserify
> npm http GET https://registry.npmjs.org/tty-browserify
> npm http GET https://registry.npmjs.org/umd
> npm http GET https://registry.npmjs.org/url
> npm http GET https://registry.npmjs.org/util
> npm http GET https://registry.npmjs.org/vm-browserify
> npm http GET https://registry.npmjs.org/wordwrap
> npm http 304 https://registry.npmjs.org/browser-pack
> npm http 304 https://registry.npmjs.org/JSONStream
> npm http 304 https://registry.npmjs.org/browser-resolve
> npm http 304 https://registry.npmjs.org/browserify-zlib
> npm http 304 https://registry.npmjs.org/assert
> npm http 304 https://registry.npmjs.org/buffer
> npm http 304 https://registry.npmjs.org/builtins
> npm http 304 https://registry.npmjs.org/commondir/0.0.1
> npm http 304 https://registry.npmjs.org/concat-stream
> npm http 304 https://registry.npmjs.org/console-browserify
> npm http 304 https://registry.npmjs.org/constants-browserify
> npm http 304 https://registry.npmjs.org/crypto-browserify
> npm http 304 https://registry.npmjs.org/deep-equal
> npm http 304 https://registry.npmjs.org/defined
> npm http 304 https://registry.npmjs.org/deps-sort
> npm http 304 https://registry.npmjs.org/derequire
> npm http 304 https://registry.npmjs.org/domain-browser
> npm http 304 https://registry.npmjs.org/duplexer
> npm http 304 https://registry.npmjs.org/events
> npm http 304 https://registry.npmjs.org/glob
> npm http 304 https://registry.npmjs.org/http-browserify
> npm http 304 https://registry.npmjs.org/https-browserify
> npm http 304 https://registry.npmjs.org/insert-module-globals
> npm http 304 https://registry.npmjs.org/module-deps
> npm http 304 https://registry.npmjs.org/os-browserify
> npm http 304 https://registry.npmjs.org/inherits
> npm http 304 https://registry.npmjs.org/parents
> npm http 304 https://registry.npmjs.org/path-browserify
> npm http 304 https://registry.npmjs.org/punycode
> npm http 304 https://registry.npmjs.org/resolve
> npm http 304 https://registry.npmjs.org/shallow-copy/0.0.1
> npm http 304 https://registry.npmjs.org/shell-quote
> npm http 304 https://registry.npmjs.org/stream-browserify
> npm http 304 https://registry.npmjs.org/stream-combiner
> npm http 304 https://registry.npmjs.org/querystring-es3/0.2.0
> npm http 304 https://registry.npmjs.org/string_decoder
> npm http 304 https://registry.npmjs.org/subarg/0.0.1
> npm http 304 https://registry.npmjs.org/syntax-error
> npm http 304 https://registry.npmjs.org/through2
> npm http 304 https://registry.npmjs.org/timers-browserify
> npm http 304 https://registry.npmjs.org/tty-browserify
> npm http 304 https://registry.npmjs.org/umd
> npm http 304 https://registry.npmjs.org/url
> npm http 304 https://registry.npmjs.org/util
> npm http 304 https://registry.npmjs.org/vm-browserify
> npm http 304 https://registry.npmjs.org/wordwrap
> npm http GET https://registry.npmjs.org/readable-stream
> npm http GET https://registry.npmjs.org/xtend
> npm http GET https://registry.npmjs.org/minimist
> npm http GET https://registry.npmjs.org/minimist
> npm http GET https://registry.npmjs.org/path-platform
> npm http GET https://registry.npmjs.org/rfile
> npm http GET https://registry.npmjs.org/ruglify
> npm http GET https://registry.npmjs.org/process
> npm http GET https://registry.npmjs.org/indexof/0.0.1
> npm http GET https://registry.npmjs.org/typedarray
> npm http GET https://registry.npmjs.org/readable-stream
> npm http GET https://registry.npmjs.org/amdefine
> npm http 304 https://registry.npmjs.org/xtend
> npm http 304 https://registry.npmjs.org/readable-stream
> npm http 304 https://registry.npmjs.org/minimist
> npm http 304 https://registry.npmjs.org/rfile
> npm http 304 https://registry.npmjs.org/minimist
> npm http 304 https://registry.npmjs.org/ruglify
> npm http 304 https://registry.npmjs.org/path-platform
> npm http 304 https://registry.npmjs.org/process
> npm http GET https://registry.npmjs.org/acorn
> npm http 304 https://registry.npmjs.org/indexof/0.0.1
> npm http 304 https://registry.npmjs.org/typedarray
> npm http 304 https://registry.npmjs.org/readable-stream
> npm http 304 https://registry.npmjs.org/amdefine
> npm http 304 https://registry.npmjs.org/acorn
> npm http GET https://registry.npmjs.org/lexical-scope
> npm http GET https://registry.npmjs.org/combine-source-map
> npm http 304 https://registry.npmjs.org/lexical-scope
> npm http 304 https://registry.npmjs.org/combine-source-map
> npm http GET https://registry.npmjs.org/callsite
> npm http GET https://registry.npmjs.org/object-keys
> npm http 304 https://registry.npmjs.org/callsite
> npm http 304 https://registry.npmjs.org/object-keys
> npm http GET https://registry.npmjs.org/minimatch
> npm http 304 https://registry.npmjs.org/minimatch
> npm http GET https://registry.npmjs.org/core-util-is
> npm http GET https://registry.npmjs.org/isarray/0.0.1
> npm http 304 https://registry.npmjs.org/isarray/0.0.1
> npm http 304 https://registry.npmjs.org/core-util-is
> npm http GET https://registry.npmjs.org/pako
> npm http GET https://registry.npmjs.org/source-map
> npm http GET https://registry.npmjs.org/inline-source-map
> npm http GET https://registry.npmjs.org/convert-source-map
> npm http 304 https://registry.npmjs.org/convert-source-map
> npm http 304 https://registry.npmjs.org/source-map
> npm http 304 https://registry.npmjs.org/inline-source-map
> npm http 304 https://registry.npmjs.org/pako
> npm http GET https://registry.npmjs.org/lru-cache
> npm http GET https://registry.npmjs.org/sigmund
> npm http 304 https://registry.npmjs.org/sigmund
> npm http 304 https://registry.npmjs.org/lru-cache
> npm http GET https://registry.npmjs.org/parents/0.0.2
> npm http GET https://registry.npmjs.org/detective
> npm http GET https://registry.npmjs.org/esprima-fb
> npm http GET https://registry.npmjs.org/estraverse
> npm http GET https://registry.npmjs.org/esrefactor
> npm http 304 https://registry.npmjs.org/parents/0.0.2
> npm http 304 https://registry.npmjs.org/detective
> npm http 304 https://registry.npmjs.org/estraverse
> npm http 304 https://registry.npmjs.org/esprima-fb
> npm http 304 https://registry.npmjs.org/esrefactor
> npm http GET https://registry.npmjs.org/astw
> npm http 304 https://registry.npmjs.org/astw
> npm http GET https://registry.npmjs.org/jsonparse/0.0.5
> npm http GET https://registry.npmjs.org/esprima-fb/3001.1.0-dev-harmony-fb
> npm http GET https://registry.npmjs.org/uglify-js
> npm http GET https://registry.npmjs.org/esprima
> npm http GET https://registry.npmjs.org/escope
> npm http GET https://registry.npmjs.org/escodegen
> npm http GET https://registry.npmjs.org/through
> npm http 304 https://registry.npmjs.org/jsonparse/0.0.5
> npm http 304 https://registry.npmjs.org/esprima-fb/3001.1.0-dev-harmony-fb
> npm http 304 https://registry.npmjs.org/uglify-js
> npm http 304 https://registry.npmjs.org/through
> npm http 304 https://registry.npmjs.org/escodegen
> npm http 304 https://registry.npmjs.org/escope
> npm http 304 https://registry.npmjs.org/esprima
> npm http GET https://registry.npmjs.org/esutils
> npm http 304 https://registry.npmjs.org/esutils
> npm http GET https://registry.npmjs.org/Base64
> npm http 304 https://registry.npmjs.org/Base64
> npm http GET https://registry.npmjs.org/optimist
> npm http 304 https://registry.npmjs.org/optimist
> npm http GET https://registry.npmjs.org/wordwrap
> npm http GET https://registry.npmjs.org/base64-js
> npm http GET https://registry.npmjs.org/ieee754
> npm http 304 https://registry.npmjs.org/wordwrap
> npm http 304 https://registry.npmjs.org/base64-js
> npm http 304 https://registry.npmjs.org/ieee754
> npm http GET https://registry.npmjs.org/amdefine
> npm http 304 https://registry.npmjs.org/amdefine
> npm WARN prefer global npm@1.3.4 should be installed with -g
> npm WARN unmet dependency ~/Cordova/cordova-lib/cordova-lib/node_modules/npmconf requires
osenv@'0.0.3' but will load
> npm WARN unmet dependency ~/Cordova/cordova-lib/cordova-lib/node_modules/osenv,
> npm WARN unmet dependency which is version 0.1.0
> npm WARN unmet dependency ~/Cordova/cordova-lib/cordova-lib/node_modules/temp requires
osenv@'0.0.3' but will load
> npm WARN unmet dependency ~/Cordova/cordova-lib/cordova-lib/node_modules/osenv,
> npm WARN unmet dependency which is version 0.1.0
> npm WARN unmet dependency ~/Cordova/cordova-lib/cordova-lib/node_modules/jasmine-node/node_modules/gaze/node_modules/fileset
requires glob@'3.x' but will load
> npm WARN unmet dependency ~/Cordova/cordova-lib/cordova-lib/node_modules/glob,
> npm WARN unmet dependency which is version 4.0.6
> cordova-js@3.7.2 node_modules/cordova-js
> ├── through@2.3.4
> ├── uglify-js@2.4.15 (uglify-to-browserify@1.0.2, async@0.2.10, optimist@0.3.7,
source-map@0.1.34)
> └── browserify@3.46.0 (https-browserify@0.0.0, builtins@0.0.7, tty-browserify@0.0.0,
constants-browserify@0.0.1, path-browserify@0.0.0, os-browserify@0.1.2, inherits@2.0.1, commondir@0.0.1,
defined@0.0.0, domain-browser@1.1.3, stream-combiner@0.0.4, duplexer@0.1.1, shell-quote@0.0.1,
deep-equal@0.1.2, shallow-copy@0.0.1, console-browserify@1.0.3, assert@1.1.2, querystring-es3@0.2.0,
punycode@1.2.4, string_decoder@0.0.1, url@0.10.1, util@0.10.3, events@1.0.2, timers-browserify@1.0.3,
parents@0.0.3, vm-browserify@0.0.4, stream-browserify@0.1.3, resolve@0.6.3, browser-resolve@1.2.4,
subarg@0.0.1, through2@0.4.2, concat-stream@1.4.7, glob@3.2.11, JSONStream@0.7.4, deps-sort@0.1.2,
browserify-zlib@0.1.4, http-browserify@1.3.2, browser-pack@2.0.1, crypto-browserify@1.0.9,
buffer@2.1.13, umd@2.0.0, derequire@0.8.0, syntax-error@1.1.2, module-deps@1.10.0, insert-module-globals@5.0.1)
> ~/npm/lib/node_modules/cordova-lib -> ~/Cordova/cordova-lib/cordova-lib
> ~/Cordova
> ~/Cordova/cordova-plugman ~/Cordova
> unbuild cordova-lib@4.1.3-dev
> ~/Cordova/cordova-plugman/node_modules/cordova-lib -> ~/npm/lib/node_modules/cordova-lib
-> ~/Cordova/cordova-lib/cordova-lib
> ~/Cordova
> ~/Cordova/cordova-cli ~/Cordova
> unbuild cordova-lib@4.1.3-dev
> ~/Cordova
> {quote}
> {quote}
> ~/Cordova $ node cordova-mobile-spec/createmobilespec/createmobilespec.js --blackberry10
> Creating project from local git repos. If you have any errors, it may be from missing
repositories.
> To clone repositories:
>   ./cordova-coho/coho repo-clone -r mobile-spec -r plugin-test-framework -r cli -r lib
-r plugman -r blackberry10 -r js -r plugins
>   mkdir cordova-cli/node_modules
>   (cd cordova-lib/cordova-lib/ && npm install)
>   (cd cordova-plugman/ && npm install)
>   mkdir cordova-cli/node_modules
>   ln -s ../../cordova-lib/cordova-lib cordova-cli/node_modules
>   (cd cordova-cli && npm install)
> To update all repositories:
>   ./cordova-coho/coho repo-update
> Checking if you are using master branch of tools
> refs/heads/master
> refs/heads/master
> You are on master branch of tools, checking npm links
> ~/Cordova/cordova-mobile-spec/createmobilespec/createmobilespec.js:281
>             throw new Error('Module ' + linkedModule + ' installed in ' + inst
>                   ^
> Error: Module cordova-js installed in cordova-lib is not npm-linked. I recommend you
run "coho npm-link".
>     at verifyNpmLinkOf (~/Cordova/cordova-mobile-spec/createmobilespec/createmobilespec.js:281:19)
>     at Object.<anonymous> (~/Cordova/cordova-mobile-spec/createmobilespec/createmobilespec.js:301:9)
>     at Module._compile (module.js:456:26)
>     at Object.Module._extensions..js (module.js:474:10)
>     at Module.load (module.js:356:32)
>     at Function.Module._load (module.js:312:12)
>     at Function.Module.runMain (module.js:497:10)
>     at startup (node.js:119:16)
>     at node.js:901:3
> {quote}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message