cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joe Bowser (JIRA)" <>
Subject [jira] [Resolved] (CB-8009) "cordova platform add android" fails even after android-19 is installed
Date Tue, 25 Nov 2014 19:01:13 GMT


Joe Bowser resolved CB-8009.
    Resolution: Incomplete


> "cordova platform add android" fails even after android-19 is installed
> -----------------------------------------------------------------------
>                 Key: CB-8009
>                 URL:
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Android
>    Affects Versions: 3.5.0
>         Environment: Low-Latency Linux AKA Ubuntu Studio 14.04.1 LTS with LXDE desktop
>            Reporter: Bass Cannon
>              Labels: android, cordova, platform
> /home/bass/.cordova/lib/npm_cache/cordova-android/3.6.4/package/bin/node_modules/q/q.js:126
>                     throw e;
>                           ^
> Error: Please install Android target "android-19".
> Hint: Run "android" from your command-line to open the SDK manager.
>     at /home/bass/.cordova/lib/npm_cache/cordova-android/3.6.4/package/bin/lib/check_reqs.js:174:19
>     at _fulfilled (/home/bass/.cordova/lib/npm_cache/cordova-android/3.6.4/package/bin/node_modules/q/q.js:798:54)
>     at self.promiseDispatch.done (/home/bass/.cordova/lib/npm_cache/cordova-android/3.6.4/package/bin/node_modules/q/q.js:827:30)
>     at Promise.promise.promiseDispatch (/home/bass/.cordova/lib/npm_cache/cordova-android/3.6.4/package/bin/node_modules/q/q.js:760:13)
>     at /home/bass/.cordova/lib/npm_cache/cordova-android/3.6.4/package/bin/node_modules/q/q.js:574:44
>     at flush (/home/bass/.cordova/lib/npm_cache/cordova-android/3.6.4/package/bin/node_modules/q/q.js:108:17)
>     at process._tickCallback (node.js:419:13)
> Error: /home/bass/.cordova/lib/npm_cache/cordova-android/3.6.4/package/bin/create: Command
failed with exit code 8
>     at ChildProcess.whenDone (/usr/lib/node_modules/cordova/node_modules/cordova-lib/src/cordova/superspawn.js:135:23)
>     at ChildProcess.emit (events.js:98:17)
>     at maybeClose (child_process.js:756:16)
>     at Process.ChildProcess._handle.onexit (child_process.js:823:5)
> -------------------------------------------
> I have just endeavored into PhoneGap using Ripple emulator via Chrome.
> I have been following this tutorial for Installing Ripple:
> However, when I get to cordova platform add android, it fails even after install android-19,
android-17, android-19.1 and android-20. It states that android SDKs aren't installed, as
is stated in the error record above.
> I am at a loss for why this is, however I am certain the resolution can be reached with
our collective knowledge and skills. In the meantime, I will be meandering through the JavaScript
source for cordova and trying to understand where the error emerges from.
> Cordially,
> Jacob Bass Cannon

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message