cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Colin Bau (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CB-7771) "media-capture" bugs with WP8.1
Date Sun, 09 Nov 2014 14:37:34 GMT

     [ https://issues.apache.org/jira/browse/CB-7771?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Colin Bau updated CB-7771:
--------------------------
    Description: 
this is my original screenshot
http://www.littlebau.com/20141013_wp/01.png

issue 1
when I execute
navigator.device.capture.captureAudio(captureSuccess, captureError, options);
it will show this
http://www.littlebau.com/20141013_wp/02.png

if I press "start",the duration will run,but if I press "take"...nothing real happened
if I press the hardware "backbutton",but it will not trigger the "captureError" callback

issue 2
when I execute
navigator.device.capture.captureImage(captureSuccess, captureError, options);
it will show the user interface to do some function
but...

if I press the "backbutton",it although trigger the "captureError" callback,but get the
"error.code" => undefined

issue 3
when I execute
navigator.device.capture.captureVideo(captureSuccess, captureError, options);
it will show the user interface to do some function
http://www.littlebau.com/20141013_wp/03.png
but...


if I press "record" button,sometimes it will become black screen
http://www.littlebau.com/20141013_wp/04.png
and when change back to my app,my webview become so strang and very small (immediately press
the "backbutton" will cause the same situation)
http://www.littlebau.com/20141013_wp/05.png

  was:
this is my original screenshot
http://www.littlebau.com/20141013_wp/01.png

issue 1
when I execute
navigator.device.capture.captureAudio(captureSuccess, captureError, options);
it will show this
http://www.littlebau.com/20141013_wp/02.png

if I press "start",the duration will run,but if I press "take"...nothing real happened
if I press the hardware "backbutton",but it will not trigger the "captureError" callback

issue 2
when I execute
navigator.device.capture.captureImage(captureSuccess, captureError, options);
it will show the user interface to do some function
but...

if I press the "backbutton",it although trigger the "captureError" callback,but get the
"error.code" => undefined

issue 3
when I execute
navigator.device.capture.captureVideo(captureSuccess, captureError, options);
it will show the user interface to do some function
http://www.littlebau.com/20141013_wp/03.png
but...


if I press "recoed" button,sometimes it will become black screen
http://www.littlebau.com/20141013_wp/04.png
and when change back to my app,my webview become so strang and very small (immediately press
the "backbutton" will cause the same situation)
http://www.littlebau.com/20141013_wp/05.png


> "media-capture" bugs with WP8.1
> -------------------------------
>
>                 Key: CB-7771
>                 URL: https://issues.apache.org/jira/browse/CB-7771
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: WP8
>    Affects Versions: 3.6.3
>         Environment: I using WP8.1 with phonegap 3.6.3 and all latest core plugin...
>            Reporter: Colin Bau
>            Assignee: Jesse MacFadyen
>              Labels: media-capture
>
> this is my original screenshot
> http://www.littlebau.com/20141013_wp/01.png
> issue 1
> when I execute
> navigator.device.capture.captureAudio(captureSuccess, captureError, options);
> it will show this
> http://www.littlebau.com/20141013_wp/02.png
> if I press "start",the duration will run,but if I press "take"...nothing real happened
> if I press the hardware "backbutton",but it will not trigger the "captureError" callback
> issue 2
> when I execute
> navigator.device.capture.captureImage(captureSuccess, captureError, options);
> it will show the user interface to do some function
> but...
> if I press the "backbutton",it although trigger the "captureError" callback,but get
the "error.code" => undefined
> issue 3
> when I execute
> navigator.device.capture.captureVideo(captureSuccess, captureError, options);
> it will show the user interface to do some function
> http://www.littlebau.com/20141013_wp/03.png
> but...
> if I press "record" button,sometimes it will become black screen
> http://www.littlebau.com/20141013_wp/04.png
> and when change back to my app,my webview become so strang and very small (immediately
press the "backbutton" will cause the same situation)
> http://www.littlebau.com/20141013_wp/05.png



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message