cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shazron Abdullah (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CB-7915) Upgrading "nopt" to 3.0.1 breaks plugman interface
Date Fri, 31 Oct 2014 05:49:34 GMT
Shazron Abdullah created CB-7915:
------------------------------------

             Summary: Upgrading "nopt" to 3.0.1 breaks plugman interface
                 Key: CB-7915
                 URL: https://issues.apache.org/jira/browse/CB-7915
             Project: Apache Cordova
          Issue Type: Bug
          Components: Plugman
            Reporter: Shazron Abdullah
            Priority: Blocker


Upgrading "nopt" to 3.0.1 breaks command line parsing. Reverting to 1.0.9 fixes this.

For example:
{code}
plugman create --name Foobar --plugin_id Foobar.id --plugin_version 0.1.1
{code}

The parser treats the value of the three variables as "true" (since they 'exist' but have
no value). With nopt 3.0.1, to assign the variables, you would need to have an assignment
using the "=" operator:
{code}
plugman create --name=Foobar --plugin_id=Foobar.id --plugin_version=0.1.1
{code}

Doing this however, breaks the interface.




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message