cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jenny Gee (JIRA)" <>
Subject [jira] [Created] (CB-7738) cordova-lib npm-shrinkwrap causes problems if using npm2.1.*
Date Wed, 08 Oct 2014 16:48:34 GMT
Jenny Gee created CB-7738:

             Summary: cordova-lib npm-shrinkwrap causes problems if using npm2.1.*
                 Key: CB-7738
             Project: Apache Cordova
          Issue Type: Bug
          Components: CordovaLib
         Environment: npm2.1.1 installed (or npm2.1.2)
            Reporter: Jenny Gee

We're trying to use npm2 because of race bugs in npm1 on our build machine.
Unfortunately, cordova-lib has a npm-shrinkwrap which makes it a pain to install cordova-lib
using npm2.

Actual results:
09:33:36 npm WARN prefer global npm@2.1.1 should be installed with -g
09:33:36 npm@2.1.1 node_modules/npm
09:33:36 2.1.1
09:34:15 npm WARN engine npm@1.3.4: wanted: {"node":">=0.6","npm":"1"} (current: {"node":"0.10.32","npm":"2.1.1"})

Expected results:
1. package.json should require npm >=1.3.4 instead of npm=1.3.4
2. npm-shrinkgwrap should not exist so that it doesn't force npm==1.3.4
3. the output above should not include an npm WARN engine npm@1.3.4: wanted message :)

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message