cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Gill (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-7363) Do not insist on precise version of cordova-lib
Date Thu, 21 Aug 2014 21:52:12 GMT

    [ https://issues.apache.org/jira/browse/CB-7363?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14106017#comment-14106017
] 

Steve Gill commented on CB-7363:
--------------------------------

going back into cli after my enviroment is setup from above, and running npm install will
not nuke my linked modules. 

EX:

Stevens-MacBook-Air-2:cordova-cli stevengill$ npm install
Stevens-MacBook-Air-2:cordova-cli stevengill$ cd node_modules/
Stevens-MacBook-Air-2:node_modules stevengill$ ls -al
total 24
drwxr-xr-x  10 stevengill  staff   340 Aug 21 14:46 .
drwxr-xr-x  21 stevengill  staff   714 Aug 21 14:46 ..
drwxr-xr-x   4 stevengill  staff   136 Jul 22 16:33 .bin
lrwxr-xr-x   1 stevengill  staff    39 Jul 30 15:04 cordova-lib -> /usr/local/lib/node_modules/cordova-lib
drwxr-xr-x  16 stevengill  staff   544 Jul 22 16:33 jasmine-node
drwxr-xr-x  11 stevengill  staff   374 Jul 22 16:33 nopt
-rw-r--r--   1 stevengill  staff  4298 Aug 21 14:46 npm-debug.log
drwxr-xr-x  10 stevengill  staff   340 May 23 16:59 optimist
drwxr-xr-x   9 stevengill  staff   306 May 23 16:59 q
drwxr-xr-x  14 stevengill  staff   476 May 23 16:59 underscore

As you ca see, my npm link cordova-lib survived the npm install

> Do not insist on precise version of cordova-lib
> -----------------------------------------------
>
>                 Key: CB-7363
>                 URL: https://issues.apache.org/jira/browse/CB-7363
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: CLI, Plugman
>    Affects Versions: 3.5.0
>            Reporter: Josh Soref
>            Assignee: Josh Soref
>
> Currently plugman's {{package.json}} has:
> {quote}
>     "cordova-lib" : "0.21.6",
> {quote}
> Unfortunately, my git repo (from coho) of {{cordova-lib}} has {{0.21.8-dev}}, which means
that if I do {{npm install}} in {{cordova-plugman}}, and I have a _symlink_ to {{cordova-lib}}
in its {{node_modules}}, the _symlink_ is *obliterated*. This isn't desirable and makes a
totally mess out of git repositories.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message