cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Luigi (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-7281) "cordova plugin add" issues nonsense EACCESS error
Date Mon, 25 Aug 2014 18:34:59 GMT

    [ https://issues.apache.org/jira/browse/CB-7281?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14109470#comment-14109470
] 

Luigi commented on CB-7281:
---------------------------

Same issue here.

It seems that once cordova is installed, updated through 
sudo npm install -g cordova

it changes owner to user tmp dir.

I just deleted it (after checking nothing relevant was there) and all went fine.

> "cordova plugin add" issues nonsense EACCESS error
> --------------------------------------------------
>
>                 Key: CB-7281
>                 URL: https://issues.apache.org/jira/browse/CB-7281
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Plugins
>         Environment: ubuntu 14.04
>            Reporter: teo
>
> On a freshly created test application targeted at android, which works fine.
> I ran:
> $ cordova plugin add nl.sylvain.cordova.osc
> Fetching plugin "nl.sylvain.cordova.osc" via plugin registry
> Error: EACCES, mkdir '/home/teo/tmp/npm-20870-r97koGWy'
> That doesn't make sense, as /home/teo is my home directory (I was running the above command
as "teo"). There's no reason why that mkdir command should get an access denied error (if
that's what EACCESS means).
> This worked:
> $ sudo cordova plugin add nl.sylvain.cordova.osc
> however, there's no reason why sudo should be needed.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message