cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Asier Iturralde Sarasola (JIRA)" <>
Subject [jira] [Commented] (CB-7281) "cordova plugin add" issues nonsense EACCESS error
Date Thu, 28 Aug 2014 08:59:57 GMT


Asier Iturralde Sarasola commented on CB-7281:

I have the same issue using cordova 3.5.0-0.2.7.

I solved the problem setting my user as the owner of the folder /home/asier/tmp/, previously
the owner was root.

> "cordova plugin add" issues nonsense EACCESS error
> --------------------------------------------------
>                 Key: CB-7281
>                 URL:
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Plugins
>         Environment: ubuntu 14.04
>            Reporter: teo
> On a freshly created test application targeted at android, which works fine.
> I ran:
> $ cordova plugin add nl.sylvain.cordova.osc
> Fetching plugin "nl.sylvain.cordova.osc" via plugin registry
> Error: EACCES, mkdir '/home/teo/tmp/npm-20870-r97koGWy'
> That doesn't make sense, as /home/teo is my home directory (I was running the above command
as "teo"). There's no reason why that mkdir command should get an access denied error (if
that's what EACCESS means).
> This worked:
> $ sudo cordova plugin add nl.sylvain.cordova.osc
> however, there's no reason why sudo should be needed.

This message was sent by Atlassian JIRA

View raw message