cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Grieve (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (CB-7114) Android: add support of min/max/target SDK to config.xml
Date Wed, 20 Aug 2014 15:18:26 GMT

     [ https://issues.apache.org/jira/browse/CB-7114?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andrew Grieve resolved CB-7114.
-------------------------------

    Resolution: Fixed

Fixed in cordova-lib-0.21.8-dev

> Android: add support of min/max/target SDK to config.xml
> --------------------------------------------------------
>
>                 Key: CB-7114
>                 URL: https://issues.apache.org/jira/browse/CB-7114
>             Project: Apache Cordova
>          Issue Type: New Feature
>          Components: Android, CordovaLib
>    Affects Versions: 3.5.0
>            Reporter: Sergey Grebnov
>            Assignee: Sergey Grebnov
>            Priority: Minor
>
> Discussed via mailing list: "Android: add support of min/max/target SDK to config.xml"

> Summary:
> Propose to add support of the following Android specific settings to config.xml similar
to PG Build[2]. Optional, could be used to override default template values. I think this
could be very useful and will implement this if we agree. Thoughts?
> <preference name="android-minSdkVersion" value="10" /> <preference name="android-targetSdkVersion"
value="19" /> <preference name="android-maxSdkVersion" value="20" />
> [1] http://developer.android.com/guide/topics/manifest/uses-sdk-element.html
> [2] http://docs.build.phonegap.com/en_US/configuring_preferences.md.html#_android_only



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message