cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pascal Widdershoven (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CB-7124) `cordova platform add <platform>@<version>` not working for Git based installs
Date Fri, 11 Jul 2014 18:22:04 GMT
Pascal Widdershoven created CB-7124:
---------------------------------------

             Summary: `cordova platform add <platform>@<version>` not working
for Git based installs
                 Key: CB-7124
                 URL: https://issues.apache.org/jira/browse/CB-7124
             Project: Apache Cordova
          Issue Type: Bug
          Components: CLI
    Affects Versions: 3.5.0
            Reporter: Pascal Widdershoven


Currently the `cordova platform add <platform>@<version>` is only working with
the `--usenpm` option enabled.

I think --usenpm is disabled by default (?) so this feature will appear broken to most users.
I've pinpointed the problem to [this peace of code|https://github.com/apache/cordova-lib/blob/master/cordova-lib/src/cordova/lazy_load.js#L86]
where for the cordova_git function the @version check is missing.

I hope I can find some time to sign the ICLA and send a pull request. In general it seems
that the whole @version check could be handled more elegantly, right now it's duplicated in
several places making it easy to forget to add it somewhere.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message