cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James White (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CB-6933) Add simulator OS version option to iOS platform run/emulate scripts
Date Thu, 12 Jun 2014 18:37:03 GMT

     [ https://issues.apache.org/jira/browse/CB-6933?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

James White updated CB-6933:
----------------------------

    Description: 
Use case:

{noformat}
The existing "cordova run ios --emulator" and "cordova emulate ios" scripts include an option
"--target" to specify the desired simulator configuration when invoking the simulator.  The
simulator by default will launch with the latest version of the iOS being simulated.  

Adding a new option "--targetos" to the platform's run/emulate scripts would allow developers
to specify which version of iOS to start the simulator with.

ie: cordova run ios --debug --emulator --target="iPhone Retina (4-inch)" --targetos=6.1

If the "--targetos" option is provided to the run/emulate script being executed, the string
"--sdk <value>" can be appended to the TARGET_FLAG variable that gets passed to ios-sim.
{noformat}

  was:
{noformat}
Use case:

The existing "cordova run ios --emulator" and "cordova emulate ios" scripts include an option
"--target" to specify the desired simulator configuration when invoking the simulator.  The
simulator by default will launch with the latest version of the iOS being simulated.  

Adding a new option "--targetos" to the platform's run/emulate scripts would allow developers
to specify which version of iOS to start the simulator with.

ie: cordova run ios --debug --emulator --target="iPhone Retina (4-inch)" --targetos=6.1

If the "--targetos" option is provided to the run/emulate script being executed, the string
"--sdk <value>" can be appended to the TARGET_FLAG variable that gets passed to ios-sim.{/noformat}



> Add simulator OS version option to iOS platform run/emulate scripts
> -------------------------------------------------------------------
>
>                 Key: CB-6933
>                 URL: https://issues.apache.org/jira/browse/CB-6933
>             Project: Apache Cordova
>          Issue Type: Improvement
>          Components: CLI, iOS
>    Affects Versions: 3.5.0
>         Environment: iOS build environment
>            Reporter: James White
>
> Use case:
> {noformat}
> The existing "cordova run ios --emulator" and "cordova emulate ios" scripts include an
option "--target" to specify the desired simulator configuration when invoking the simulator.
 The simulator by default will launch with the latest version of the iOS being simulated.
 
> Adding a new option "--targetos" to the platform's run/emulate scripts would allow developers
to specify which version of iOS to start the simulator with.
> ie: cordova run ios --debug --emulator --target="iPhone Retina (4-inch)" --targetos=6.1
> If the "--targetos" option is provided to the run/emulate script being executed, the
string "--sdk <value>" can be appended to the TARGET_FLAG variable that gets passed
to ios-sim.
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message