cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ian Clelland (JIRA)" <>
Subject [jira] [Resolved] (CB-6844) Adding file-transfer plugin with CLI brings in broken dependencies
Date Mon, 02 Jun 2014 13:22:01 GMT


Ian Clelland resolved CB-6844.

    Resolution: Duplicate

Thanks for reporting this -- I discovered it a couple of weeks ago; it's fixed in development,
and we just need to release a new version to the plugin registry.

> Adding file-transfer plugin with CLI brings in broken dependencies
> ------------------------------------------------------------------
>                 Key: CB-6844
>                 URL:
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: CLI, Plugin File, Plugin File Transfer
>    Affects Versions: 3.5.0
>         Environment: Mac OS X with iOS platform
>            Reporter: Andre Alves Garzia
>              Labels: easyfix
> If one tries to add the file transfer plugin with:
> cordova plugin add org.apache.cordova.file-transfer
> It will bring in its dependency which is org.apache.cordova.file but the current version
of that plugin is not listed as compatible with the current version of org.apache.cordova.file-transfer
so you end up with this:
> WARNING, broken dependency: plugin org.apache.cordova.file-transfer depends on org.apache.cordova.file
1.0.1 but installed version is 1.1.0

This message was sent by Atlassian JIRA

View raw message