cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shazron Abdullah (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (CB-6821) Cordova does not build under certain build settings
Date Fri, 30 May 2014 17:05:03 GMT

    [ https://issues.apache.org/jira/browse/CB-6821?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14013939#comment-14013939
] 

Shazron Abdullah edited comment on CB-6821 at 5/30/14 5:03 PM:
---------------------------------------------------------------

This is only for the Debug config because "Build Active Architecture Only" is set to Yes for
faster debugging. To enable only armv7 in the Debug config, set "Build Active Architecture
Only" to No in both the Project and CordovaLib Build Settings. The "Active Architecture" depends
on what device is connected (so for my iPhone 5s, it's arm64)


was (Author: shazron):
This is only for the Debug config because "Build Active Architecture Only" is set to Yes for
faster debugging. To enable only armv7 in the Debug config, set "Build Active Architecture
Only" to No in both the Project and CordovaLib.settings. The "Active Architecture" depends
on what device is connected (so for my iPhone 5s, it's arm64)

> Cordova does not build under certain build settings
> ---------------------------------------------------
>
>                 Key: CB-6821
>                 URL: https://issues.apache.org/jira/browse/CB-6821
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: iOS
>    Affects Versions: 3.5.0
>         Environment: OSX 10.9.3, XCODE 5.1.1, iOS 7.1.1 (device)
>            Reporter: Song Zheng
>
> 1. Create a new project: cordova create projectName
> 2. Add iOS platform: cordova platform add ios
> 3. Open Xcode: open projectName/platform/ios/..xcodeproj
> 4. Change project settings:
>     * Valid Architectures: armv7 (remove arm64 and armv7s)
>     * Build Active Architecture Only - NO
> Expected behavior: Compile and run on device
> Result (error):
> Undefined symbols for architecture armv7:
>   "_OBJC_METACLASS_$_CDVCommandDelegateImpl", referenced from:
>       _OBJC_METACLASS_$_MainCommandDelegate in MainViewController.o
>   "_OBJC_CLASS_$_CDVCommandQueue", referenced from:
>       _OBJC_CLASS_$_MainCommandQueue in MainViewController.o
>   "_OBJC_METACLASS_$_CDVViewController", referenced from:
>       _OBJC_METACLASS_$_MainViewController in MainViewController.o
>   "_OBJC_METACLASS_$_CDVCommandQueue", referenced from:
>       _OBJC_METACLASS_$_MainCommandQueue in MainViewController.o
>   "_CDVPluginHandleOpenURLNotification", referenced from:
>       -[AppDelegate application:openURL:sourceApplication:annotation:] in AppDelegate.o
>   "_OBJC_CLASS_$_CDVViewController", referenced from:
>       _OBJC_CLASS_$_MainViewController in MainViewController.o
>   "_CDVRemoteNotificationError", referenced from:
>       -[AppDelegate application:didFailToRegisterForRemoteNotificationsWithError:] in
AppDelegate.o
>   "_CDVRemoteNotification", referenced from:
>       -[AppDelegate application:didRegisterForRemoteNotificationsWithDeviceToken:] in
AppDelegate.o
>   "_OBJC_CLASS_$_CDVCommandDelegateImpl", referenced from:
>       _OBJC_CLASS_$_MainCommandDelegate in MainViewController.o
>   "_CDVLocalNotification", referenced from:
>       -[AppDelegate application:didReceiveLocalNotification:] in AppDelegate.o
> ld: symbol(s) not found for architecture armv7
> clang: error: linker command failed with exit code 1 (use -v to see invocation)



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message