cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Grieve (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (CB-6623) Android WebView class not using evaluateJavascript when platform >= 19
Date Mon, 05 May 2014 14:23:15 GMT

     [ https://issues.apache.org/jira/browse/CB-6623?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andrew Grieve resolved CB-6623.
-------------------------------

    Resolution: Not a Problem

Calling webView.sendJavascript() does the right thing I think. If plugins call loadUrl() directly
with a javascript:, then I don't think we should be mucking with this. 

> Android WebView class not using evaluateJavascript when platform >= 19
> ----------------------------------------------------------------------
>
>                 Key: CB-6623
>                 URL: https://issues.apache.org/jira/browse/CB-6623
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Android
>    Affects Versions: 3.4.0
>            Reporter: Graham Mueller
>
> I noticed there have been a couple issues (CB-5756 and CB-6052) that seem to refer to
the usage of loadUrl for javascript: calls. In 4.4 this causes the page to load to fail, and
the InAppBrowser was updated.
> The WebView itself is still calling loadUrl for everything though -- see lines 509-516
of that class (loadWebViewNow). Shouldn't this be updated to instead use evaluateJavascript
if the SDK_INT is >= 19?



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message