cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "brian johnston (JIRA)" <>
Subject [jira] [Commented] (CB-6566) Windows 8 cannot read files
Date Sat, 03 May 2014 03:40:17 GMT


brian johnston commented on CB-6566:

I got it to read files.  I installed VS 2012 Express and installed the latest Cordova 3.4
package.  Next, I transferred all my source code into Visual Studio project based on the WP8
project template.  Still, after building the project in VS2012 and running it on my Nokia
phone, the same error occurred.  So I set several breakpoints in file.cs.  I noticed the readDataUrl
method was implemented, but the others are not yet, so I tested it.  I discovered the FileEntry
method breakpoints were getting hit, but the readDataUrl method was never called.  So I moved
up into the file.js and added some console.logs.  Suddenly, the next time I ran it the debug
breakpoint in the readDataUrl method of file.cs was hit, weird. So,something was going on
with javascript, but I don't know what.  It has worked fine ever since. 

One thing I don't understand is how the browser knows to call the Cordova FileReader methods
instead of the HTML5 FileReader methods?  

> Windows 8 cannot read files
> ---------------------------
>                 Key: CB-6566
>                 URL:
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: WP8
>            Reporter: brian johnston
>            Assignee: Jesse MacFadyen
> The getFile fileEntry object comes back OK, except the values of fullPath, toNativeUrl
and toURL are identical.  I already reported that.  However, the fileEntry.isFile says "true"
so I assumed something was there.  However when I pass that fileEntry into a FileReader object
and try to use reader to read the file I get the following results:
> reader.readAsArrayBuffer and reader.readAsDataURL both throw a TYPE_MISMATCH_ERR.  I
saw in the docs that readAsArrayBuffer is not supported on WP8, but I figured I'd try it anyway.
> I got an error message on reader.readAsBinaryString saying that method is missing.  I'm
not surprised about that since the HTML spec says it is deprecated anyway.
> I also got a fileEntry back from window.resolveLocalFileSystemURI (had to put '///' in
front of the folder and file name to get it to work) and tried to use that.  It gave the same

This message was sent by Atlassian JIRA

View raw message