cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bryan Higgins (JIRA)" <>
Subject [jira] [Commented] (CB-5654) [BB10] make visible the version of the Cordova native lib
Date Fri, 30 May 2014 13:20:02 GMT


Bryan Higgins commented on CB-5654:

It's entirely possible for this scenario to occur on BB10 as well.

Unlike the "JS-only" platforms, BB10 does have an exec bridge. Rather than going directly
to native, the call is handled by a privileged web view, aka "the controller". This has access
to the qnx.webplatform object which drives a lot of the APIs as well as the ability to load
native code via an NPAPI plugin.

We recently did change the beahviour of the bridge to allow for async xhr rather than the
default sync. So cordova-js 3.3 is not compatible with cordova-blackberry 3.4.

BTW, As of 2.0, WebWorks is a distribution of Cordova. We bundle a custom CLI and GUI with
it, but otherwise it is functionally equivalent.

> [BB10] make visible the version of the Cordova native lib
> ---------------------------------------------------------
>                 Key: CB-5654
>                 URL:
>             Project: Apache Cordova
>          Issue Type: Sub-task
>          Components: BlackBerry
>            Reporter: Marcel Kinard
>            Assignee: Bryan Higgins
> See the parent task.

This message was sent by Atlassian JIRA

View raw message