cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-6397) [windows8] Use the latest version of MSBuild Tools installed to build the app
Date Tue, 08 Apr 2014 20:16:21 GMT

    [ https://issues.apache.org/jira/browse/CB-6397?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13963385#comment-13963385
] 

ASF GitHub Bot commented on CB-6397:
------------------------------------

Github user asfgit closed the pull request at:

    https://github.com/apache/cordova-windows/pull/20


> [windows8] Use the latest version of MSBuild Tools installed to build the app
> -----------------------------------------------------------------------------
>
>                 Key: CB-6397
>                 URL: https://issues.apache.org/jira/browse/CB-6397
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Windows 8
>    Affects Versions: 3.4.0
>         Environment: Windows8, VS2012, VS2013
>            Reporter: Sergey Grebnov
>            Assignee: Jesse MacFadyen
>             Fix For: 3.5.0
>
>
> You can manually update Windows8 template to Windows8.1 to start using Cordova to build
Windows8.1 apps. Such apps requires MSBuild Tools v12 to successfully build the code (Visual
Studio 2013 or later).
> We recently added logic to detect MSBuild version required by looking into the project
file and get MSBuild location from registry (CB-6083 [windows8] Use registry to read msbuild
tools path).
> Unfortunately, in some case it is not possible (or super hard) to detect correct version
of MSBuild required by parsing project file. The easiest and most reliable approach is to
use the latest version of MSBuild tools installed on the machine.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message