cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Gonzalez (JIRA)" <>
Subject [jira] [Commented] (CB-6326) [cordova-blackberry] target-utils.js outdated
Date Fri, 21 Mar 2014 16:31:44 GMT


Martin Gonzalez commented on CB-6326:

This issue should be resolved in order to add support for blackberry10 to cordova info command.

> [cordova-blackberry] target-utils.js outdated
> ---------------------------------------------
>                 Key: CB-6326
>                 URL:
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: BlackBerry
>    Affects Versions: 3.4.0
>            Reporter: Martin Gonzalez
>            Assignee: Martin Gonzalez
>            Priority: Blocker
>              Labels: blackberry-utils, blackberry10, cordova-cli, cordova-info
>             Fix For: 3.5.0
> The file target-utils.js, located under cordova/lib, is used to get information a about
the devices, emulators, even if those are registered in the blackberry10.json file.
> When a cordova application is created, build and then deployed into the blackberry emulator
or device, all records stays at the blackberry10.json file, that information include description,
ip, pin, and type. When emulate, it sets 'emulator', target-utils.js it looks for this file
and check the content, and it's looking for the word 'simulator', so it won't work anymore
if this word is not chaged, and replaced for 'emulator'.
> Besides, from this change it depends this issue:
> The cordova info command it will use the target-utils.js, to add support for blackberry10.

This message was sent by Atlassian JIRA

View raw message